Wireless channel control.

Here to help

Wireless channel control.

I have some smart devices that run on 2.4GHz, which is fine, as I have a dedicated wireless network set to this. However, there’s no channel configuration, and therefore, by default is set to auto. This knocks the smart devices offline, as it hates the auto-channel feature. Can there be an option to select this on/off and to hardcode the selected/preferred wireless channel?

A model citizen

I hate these auto and default setups as you run into multiple issues within office spaces where there are several radios for different orgs overlapping and shouting over each other. By using this auto approach you´ll get issues even if you haven´t changed anything in your network but the folks at next door tenants have something running automaticly which is interfering within my own network.

Meraki Go Team

@Harry_91 & @Roska -


Keep an eye out on the upcoming releases for a resolution to these issues.

James Wilson
Cisco Meraki

@Harry_91 @Roska @olavrb @JW7630 @SamDaniels @tacotaco @Davepgh @MBITJAPAN @RedServ -


2.25.0 is now available in both app stores. Release notes are below:


- All access points now support manual radio setting overrides!

- Hungarian language support has now been added to the app.

- General stability fixes and improvements

James Wilson
Cisco Meraki