cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Postman and Meraki API - newer collections are not working - receive 404 results

Comes here often

Postman and Meraki API - newer collections are not working - receive 404 results

Update: Issue resolved, un-installed postman and updated the collections. 

 

 

I have been having difficulty running the newer API's released viaPostman. No matter how I try to execute using the newer collections it never returns anything. 

 

When I switch back to an older collection - it executes fine. Same Cisco API key, same global variables. 

 

I noticed that the OpenAPI standard changed some things. For example, when retrieving networks within an organization 

 

 

 Old API calls looked like this:

 

 

<a href="<a href="https://api.meraki.com/api/v0/organizations/[organizationId]/networks" target="_blank">https://api.meraki.com/api/v0/organizations/[organizationId]/networks</a>" target="_blank"><a href="https://api.meraki.com/api/v0/organizations/[organizationId]/networks</a" target="_blank">https://api.meraki.com/api/v0/organizations/[organizationId]/networks</a</a>>

 

 

 New API calls looked like this:

 

 

<a href="<a href="https://api.meraki.com/api/v0/organizations/:organizationId/networks?configTemplateId=" target="_blank">https://api.meraki.com/api/v0/organizations/:organizationId/networks?configTemplateId=</a>" target="_blank"><a href="https://api.meraki.com/api/v0/organizations/:organizationId/networks?configTemplateId=</a" target="_blank">https://api.meraki.com/api/v0/organizations/:organizationId/networks?configTemplateId=</a</a>>

 

 

 

The brackets vs the colon is the only obvious difference, yet when I execute the same commands in Postman one is successful while the other isn't. 

 

My problem is that while I like that the older API collections work, there are new things added that I want to utilize, but I cannot seem to get to work. What am I missing other than being dense? I'm not a developer, so any help would be great. 

 

I've also attached some screenshots. new.pngNewer collection

 

old.pngOlder collection

 

2 REPLIES 2
Here to help

Re: Postman and Meraki API - newer collections are not working - receive 404 results

Watching for a response, curious as well.

Kind of a big deal

Re: Postman and Meraki API - newer collections are not working - receive 404 results


@G_ControlScan wrote:

Watching for a response, curious as well.


In case you were still waiting for the response @G_ControlScan ...

 

@bshoults82 updated the initial post saying that he solved it by:


Update: Issue resolved, un-installed postman and updated the collections.

.


 

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.