AppleTV 4K Ethernet Madness

A model citizen

AppleTV 4K Ethernet Madness

I have a few Apple TV 4K on the network. Wireless not a hassle. Wired well they are problem children.


The wired clients, every few seconds, give me Port STP changes/Port status changes as in designated→disabled/old: 1Gfdx, new: down/ old: down, new: 1Gfdx


And these are sleeping devices.


Which also give a high proportion of CRC align errors, only on received. When the Apple TV 4K's are actively streaming, Airplaying the CRC errors disappear. 


So the theory is on a wired client in order for the AppleTV to act as a HomeKit hub Apple has designed a special WOL packet that messes with Meraki Switches. And the reason the wireless clients are a bother is a) no WOL for you and b) I think Apple uses the sign into iCloud to provide that functionality.


Of course I could be way off here but has any one else seen the flapping Apple TV 4K?


I reached out to Meraki support but nothing more that, new cable, new port and new switch, all of which have not resolved.



Well just when you are bored enough to swing back around and see if the current tvOS or Meraki updates, along with fairy dust, has resolved this issue - yes it has. I no longer see CRC align errors, nothing but a sea of green!


Of course whom resolved this I do no know but it is done.




View solution in original post

Building a reputation

I’ve had a ticket open regarding this(high CRCs while sleeping) for several weeks.  Support has no clue. 

I've looked about on the internets, and see others with same issue. I filed a feature request with Apple as well. as per suggestions on Apple Forums. It would be nice if there was some info either from Apple or a proffered solution from switch vendors.

As a short term solution could you just set the devices not to sleep?

I've seen this mentioned a lot on macOS forums. It causes issues with other vendors gear as well.

Very annoying, we've seen it first hand at our clients sites

That's too bad. My setup works 100%.


I have an Apple TV 4K 64GB plugged into my MS220-8P. It works flawlessly.


I've had the Apple TV for a year or more. I've had the MS220-8P for 3+ years. For the Apple TV there are zero events on the MS120-8P log.


My MS120-8P is running MS 10.45 firmware. 


Is there anything notably different about your setup? 

MS120-8P or MS220-8P?


Any diff between MS210 and MS220?

@Richard_W wrote:
Any diff between MS210 and MS220?

If the question was really that... the MS220 (non-compact) is EOL and didn't support stacking. MS210 is a current model and supports stacking. MS220 has the compact model mentioned in this topic, the MS210 doesn't, see below.


Datasheets here:


However I assume your question was really whether there is a difference between MS120-8FP and MS220-8P. Then the answer is that the MS120-8FP is much more compact and that there's a lower PoE budget version of it called MS120-8LP. The MS220-8P is EOL.


Building a reputation

I'm on a MS 10.45, MS220-24P.  Appears to be something in the code, I have some MS220-8P on MS 8.10 and see no issues. 

@Welles So you have the issue with MS 10.45 on MS220-24P but not with MS 8.10 on MS220-8P, if I'm understanding correctly?


Building a reputation

@Richard_W Correct. 

Building a reputation

Apparently Meraki support had sent updates to the case I did have open regarding this issue. Of course the four updates, I never received any notification and they closed the case.  So I reopened it and we'll see where this goes. It sounds like they know about this bug and it's being ignored. I have sent pcaps, as they requested, and I've asked for an update, but silence from Meraki support. Which, frankly, is pretty normal when something like this occurs. I have asked to have it escalated, but, I'm sure nothing will happen. 

Head in the Cloud

Now I know this sounds a bit full of it.

But i've always found Meraki support to be really helpful, even with random bugs. They've needed a prod every now and then but who doesn't right?

Have you found them that bad?
Building a reputation

Different networks have different issues. I average 17 cases a year, 119+ tickets opened.  

Head in the Cloud

Very true, we've seen our fair few as well. Issues with systems not working as per the documentation etc. But support have always been helpful and rewritten the documentation or changed features etc

Just surprised if your overall impression of them was negative thats all
A model citizen

just to give a visual to it, note that the green connectivity is due to the device in use:


Screen Shot 2019-03-28 at 2.57.45 PM.png

Building a reputation

And mine looks like this: 



May have figured the issue.


My Apple TV 4K was on VLAN 1, once moved to a new VLAN, issues appear to have resolved.

Spoke too soon. Issue is back, still had port flapping issues regardless.
Bangs-head-on-desk kinda Monday…

I'm experiencing the same issues (port constantly bouncing and high CRCs when sleeping), however I am using a Catalyst 2960S switch.

Interestingly, I bought two Apple TV 4K (32GB) units at the same time, both are running 11.3 and connected to the same switch with exactly the same switch port configuration. One experiences the issue and the other doesn't. I've tried swapping cables, switch ports etc. to no avail. Both are connected to the same iCould account and have the same sleep settings.

The only discernible difference between the two is the TV on which they're connected: Sony Bravia (no issues) vs Samsung.

I will try swapping the Apple TVs between TVs and see if the problem moves or persists.

I also have another customer who's experiencing the same issues connecting on Ubiquiti EdgeSwitches, so I would be surprised if Meraki are able to resolve this issue.


I swapped the Apple TV 4K units between TVs, leaving the power, HDMI and network cables in their original place, and the issue moved with the Apple TV 4K.

So this tells me the issue is isolated to the Apple TV, and nothing to do with the cabling, network config or TV.

Other threads suggested that the issue may be to do with HDMI "chatter", but with the problem moving to the new location on a previously OK TV (different model, HDMI specs and cable), tells me it is not related to HDMI.

Kind of a big deal

I'm going to take a wild stab and guess it is using something like Energy Efficient Ethernet and is downshifting its speed when idle to save power, causing a link transition.

I see that on the iMacs, but this is constant when the device is sleeping.

Can confirm that I have the same issue on my MS120-48LP running MS 10.45.

I have 7 AppleTV 4k connected and all of the switchports reports very high amount of CRC-errors as soon as the AppleTV is not in use.


I got an answer from Meraki Support:

"We have re-created this issue in a lab environment, It appears that the Apple TV NIC tries to negotiate a half-duplex switch mode in sleep mode.

I can confirm that Cisco Meraki is currently speaking to Apple regarding this issue."


So hopefully Apple will update the firmware or Meraki figure out a workaround for this issue soon.

And how are we getting along with a solution for this?







Meraki Alumni (Retired)

Honest question: should this issue be in the Endpoint Management community forum? And yes, I'm trying to 'pass the buck' if indeed my switching brethren are the rightful owners of said currency. 

Yup, this hot potato is destined to be in the hands of the switching team.

@Noah_Salzman wrote:

Honest question: should this issue be in the Endpoint Management community forum? And yes, I'm trying to 'pass the buck' if indeed my switching brethren are the rightful owners of said currency. 

Passing the buck on your behalf, @Noah_Salzman! Moving this thread to the switching forum.

Caroline S | Community Manager, Cisco Meraki
New to the community? Get started here

At this point where it is, matters less to a potential resolution (I really have no idea why I put it in Endpoint 🤔.) 


So as long as a solution is forthcoming it can go wherever it may.


Sadly I believe the ball is in Apple's court on this one.


I've seen this issue on 4 different vendors switches, but not all AppleTV 4Ks display the problem.


However, I updated to the new tvOS 13.0 this morning, and since then my 4K switch port has been stable. Fingers crossed this resolves the issue!

@snowbie that sounds promising, I'm holding off a little on tvOS 13.0 just so I can get through other upgrades first, but thanks again for the update!


Just to further update, the two Apple TV 4Ks I updated to tvOS 13.0 three days ago have remained stable. No interfaces bouncing, no half-duplex, and no FCS or CRC errors.


For me, the issues were present from tvOS 11 to 12.4.1.

No relief for me, sadly 13.3 and still have high CRC errors when the appleTV is sleeping.



I was on tvOS 13.4.6 and had the same problem with my Apple TV 4K, acting has a HomeKit hub.


I tried two things:


1. Upgraded to beta of tvOS 14 and rebooted.


(problem was still there, only now a red warning bubble appeared in front of HomeKit in Settings.


2. Reset the Apple TV 4K and set it up from scratch.


So far, the problem seems to be gone after 10 minutes with the Apple TV 4K sleeping.


A bit more background on my set up. My Apple TV 4K seemed to work fine though earlier version of tvOS and may have started exhibiting this issue in May 2020 when I upgraded from an SMC 100Base-T ethernet switch to a Cisco WS-C2960S-24TS-S. About this time, my family and I noticed that Home app outside of our home's wifi was no longer working with HomeKit. With the Cisco managed switch, I was able to see half of a million "Total Receive Errors"... Since I made the change, the Apple TV 4K's Total Receive Errors haven't increased and are holding steady at 495,436. I may not be back here, but I'll post updates about my experience with this issue here.

Still an ongoing issue for me and now we are on tvOS 14.2.


One day in the not too distant future, maybe, just maybe this will be a resolved issue – but for now i just look fondly on as my little CRC align errors, with their angry redness, flow on.



Had the same issue with two Apple TV 4Ks connected to a MS390 switch. YouTube TV app would indicate a connection issue. I connected the Apple TVs to a cheap Netgear 8-Port Switch, which was then connected to the MS390 and everything worked great. Stopped troubleshooting after that. 

Head in the Cloud

Still an issue with Apple TV 4K and Meraki MS210-24P and MS225-48LP switches on different networks with firmware MS12.33 and MS14.19. Always "crc_errors_error". I have got thousands of devices, only Apple TV seems to be an anger. I tried it with auto link negotiation and fixed 1Gig and fixed 100MBit. Didn´t help. So far as I found out that the issue occures when the Apple TV goes to powersave or something.

Any suggestions?

I would certainly like to see what comes out of this. We have a few Apple TVs  in the school district at multiple buildings - and it's an annoyance to see it in Meraki - since it "thinks" there's a problem.




Up to date
Current version: MS 12.28


I opened a case because of the Apple TV odds.

They said: do an port isolation, do disable Flood unknown multicast traffic, do half duplex...

Didn´t help a lot.

The don´t know anything at the support.

Well just when you are bored enough to swing back around and see if the current tvOS or Meraki updates, along with fairy dust, has resolved this issue - yes it has. I no longer see CRC align errors, nothing but a sea of green!


Of course whom resolved this I do no know but it is done.




New here

What MS version and AppleTV version are you seeing this resolved? I am still seeing the issue with MS 14.33.1 and AppleTV 15.6

MS 14.33.1 and tvOS 16

Unfortunately, I still see the issue with MS 14.33.1 and tvOS 16



The main issue was CRC align errors, to which I no longer have any (hence issue appears resolved.)


As to the Port STP and Status changes, these still exist for me as well. A gift horse issue no?Screen Shot 2022-10-19 at 11.30.10 AM.png


Head in the Cloud

It´s definitive solved with Apple TV OS 15.6 and MS switch firmware 14.33 (MS225-48LP switches)

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.