cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Computer name not displaying properly in Description

Getting noticed

Computer name not displaying properly in Description

Recently I've noticed computer names not displaying properly in Dashboard.  I've attached a screen shot Capture 9-25-19.JPG

 

The top 3 names in the list are an example of what I'm talking about. 

 

I opened a ticket with Meraki, and they said:

 

"what you are seeing there is the MDNS name which has a higher weight than NetBIOS and DHCP when reporting to dashboard. "

 

This is also happening on Apple devices. These names just started showing up in my dashboard a couple of months ago.  This makes troubleshooting clients cumbersome.  Meraki claims nothing has changed within Dashboard's back end configuration.  Support's suggestion was to manually enter the computer name in dashboard, but that's not practical with thousands of machines over 25 separate networks.  

 

Has anyone else seen this?  Is there a way to disable mdns names in a client?  Or to change it? 

34 REPLIES 34
Kind of a big deal

Re: Computer name not displaying properly in Description

Click on the client and hit the pencil to edit the name.

 

InkedCapture_LI.jpg

Getting noticed

Re: Computer name not displaying properly in Description

That's the part I wanted to avoid, if possible.  I would have thousands of devices to update.

Building a reputation

Re: Computer name not displaying properly in Description

@CML_Todd 

 

I am having the exact same issues so opened a case a couple of months ago.

Meraki Tech replied...

 

=======The name you mentioned looks like a MDNS hostname learnt by the Dashboard. This happens when the client is reporting a hostname via MDNS packets and this overrides the NetBios and DHCP Hostname that might have been configured on the client device.

 

To mitigate this issue, there are a couple of things that can be looked into:

 

1) Verify where the MDNS hostname is configured and change it to any expected hostname that needs to be on the Dashboard.

 

2) Stop MDNS services on the client device so that it does not update the MDNS hostname on Dashboard.

 

3) Manually update the client device's hostname using the following instructions: https://documentation.meraki.com/MX/Monitoring_and_Reporting/Rename_a_Client_Hostname Hostname broadcasted by MDNS gets priority over DHCP and NetBios and hence, the hostname gets updated when the client sends MDNS traffic. Let me know if you have any questions.

 

Regards, Siddhant Marar Cisco Meraki

 

========

I was trying to disable the MDNS service from Windows PC but even I couldn't locate it.

 

Highlighted
Meraki Employee CN
Meraki Employee

Re: Computer name not displaying properly in Description

Just curious, does there seem to be any common software installed on the devices that are showing the alphanumeric name. Perhaps a remote desktop app or maybe a meeting place app? If it's happening across device types, it could be some application that is sending MDNS traffic that the MX/MR are registering as the device name. It might be doing this to try and discover other devices on the LAN network that it is able to communicate with. 

 

As @Raj66 mentioned, mDNS is going to be preferred once learned (unless renamed). 

Here to help

Re: Computer name not displaying properly in Description

No additional software is installed that would send mdns. I verified bonjour isn't installed as well. It is pretty random. It does it for windows 7 and windows 10. Each model has a different image and some of the same models display correctly on the mx and others display with the mdns like name.  Some of these systems have been on the network for a long time and suddenly about 3 months ago started doing this. The Mac systems aren't imaged, so each one is a different install.

Kind of a big deal

Re: Computer name not displaying properly in Description

I got this link from @Nash who was able to inform me.

 

https://dashboard.meraki.com/api_docs#provisions-a-client-with-a-name-and-policy

 

Hope it helps.

 

 

Kind of a big deal

Re: Computer name not displaying properly in Description

The names you are seeing are "privacy" names, and devices like Apple and Chromebooks have moved to using them on purpose.  Great for domestic users, a pain in the arse for companies.

Here to help

Re: Computer name not displaying properly in Description

We are having the same issue and it start about 3 or 4 months ago. Opened a ticket with support and was told mDNS takes priority over netbios. Wireshark showed my clients are sending the mDNS request with the weird names, so I disabled LLMNR  on the client, deleted the client from Meraki and forced an ipconfig release and renew. This still ended with zero success. My clients are still registering with the weird names.

Conversationalist

Re: Computer name not displaying properly in Description

Just chiming in to say "me too". Something obviously changed in the last few months, and not for the better. Does anybody know of a situation where it is preferable for a cryptic MDNS name to take precedence over NETBIOS name in the dashboard? There has to be a way to identify what has changed and reverse it, right?

Getting noticed

Re: Computer name not displaying properly in Description

Glad to see I'm not the only one having this problem.  Unfortunately, there doesn't seem to be a solution other than manual intervention.  I've tried many of the same steps everyone has described to no avail.  

Here to help

Re: Computer name not displaying properly in Description

I'm curious, is anyone using a firmware version before 15.12 having the issue?

Conversationalist

Re: Computer name not displaying properly in Description

I'll add a me too.  I opened a ticket in August and got the same response as everyone else. 

 

I have a network that is running 15.9 and it is reporting the mDNS names the same as my 15.15 networks.  

Getting noticed

Re: Computer name not displaying properly in Description

Yes, I'm running 14.39 on all of my networks.
Here to help

Re: Computer name not displaying properly in Description

Thanks. I just wanted to verify the change wasn't in a firmware update. It can't be a Windows update because we are recently seeing it for our Mac OS devices as well. This would seem Meraki pushed out some kind of configuration change. I reopened our ticket with support on early Friday and I am awaiting a response.

 

Can anybody with Meraki chime in?

Meraki Employee

Re: Computer name not displaying properly in Description

Hello All,

 

Just wanted to chime in and provide my point of view on this as many people are seeing this behavior in the dashboard.

 

This is definitely not related any latest firmware update or configuration change from Meraki side. The way the dashboard identifies the hostname hasn't been changed recently. It has always been the same. The preference order is, the name given manually on the dashboard > mDNS > NetBIOS > DHCP. So, if the client is generating an mDNS name for itself, that will be given priority over DHCP hostname.

 

One way to change this is to rename the client manually on the dashboard. However, if there are a large number of clients whose name needs to be changed, you can leverage this API call to rename the clients

https://dashboard.meraki.com/api_docs#provisions-a-client-with-a-name-and-policy

 

Cheers!

 

Raj

If you found this post helpful, please give it kudos. If my answer solved your problem, click "accept as solution" so that others can benefit from it
Building a reputation

Re: Computer name not displaying properly in Description

Thanks a lot for the explanation @Raj66!

Conversationalist

Re: Computer name not displaying properly in Description

Where do we all chime in for a feature request where we get a dropdown box to choose the mDNS, NetBIOS, DHCP or custom name?

 

This is a portal. This is an EASY change. Right now you just get an edit button. Can I get a million Kudos on this?

Getting noticed

Re: Computer name not displaying properly in Description

Guess we need to add it to the Make a Wish section of the client view.
Here to help

Re: Computer name not displaying properly in Description

I submitted it to the wishlist. We may all need to submitted to get it added.

Getting noticed

Re: Computer name not displaying properly in Description

I will too. That's a good idea.
Here to help

Re: Computer name not displaying properly in Description

We should have an option to choose what the mx will use to determine device names.  I have thought that since I found out mDNS has priority. 

 

@EvolutionNoel  Are you saying this is just a view setting in the portal and not actually a setting on the MX?

Getting noticed

Re: Computer name not displaying properly in Description

That's a good idea.  But that setting should probably be made at the Network level, not device level (MX) because I'm also seeing it on my AP Networks too.  

Here to help

Re: Computer name not displaying properly in Description

Agreed, the network is what holds the MX/MR configurations.

Conversationalist

Re: Computer name not displaying properly in Description

@Roux No, I am saying it SHOULD be.

WLF
New here

Re: Computer name not displaying properly in Description

We have this issue as well, very annoying. Wish and support request done.

New here

Re: Computer name not displaying properly in Description

Could ISP DNS such as googles be part of the problem?  Just curious because I did not notice the changes until a month or two after changing my ISP connection DNS to Googles.  previously I had used the ISP given DNS.  If we are looking a common settings... I also deliver DHCP to the clients using the meraki MX... along with AD DNS I allow 8.8.8.8 and of course 8.8.8.8 is also part of my servers set DNS.  Curious to see what kind of feedback I get if people are willing to put for the effort.

 

Meraki Employee CN
Meraki Employee

Re: Computer name not displaying properly in Description

Is anyone using Chromecast devices in their network? AppleTV? Roku? These devices use MDNS to find which device to cast to. It might be that during the handshake process there's just enough MDNS data to create a new name for the device. 

 

In my network, the Roku has an MDNS name of 34 characters. Chromecast 36. The macOS and iPhone have 36 character MDNS names. 

 

One way to find the true name of the devices is to use the API to get the client details. The Meraki Tools for Google Sheets add-on can be run to easily find the name of the device. 

https://community.meraki.com/t5/Developers-APIs/Meraki-Tools-for-Google-Sheets-add-on/m-p/50838

Conversationalist

Re: Computer name not displaying properly in Description

Here are some questions that I would like Meraki to address:

 

  • For the purpose of displaying clients on the dashboard, why does Meraki place a higher weight on cryptic MDNS names rather than easily identifiable names?
  • I’ve been using Meraki for over 6 years now and not until June of 2019 had I ever even seen an MDNS name for a client in the dashboard. If MDNS names have always had the highest priority why are they just now all of a sudden showing up for everybody when they never have before?
  • So far it seems like Meraki’s stance on this issue is “Well this is how it’s always been and this is expected behavior.” Does that mean for all these years that the dashboard has been displaying easily identifiable names instead of MDNS names that it was exhibiting unexpected behavior?
  • Why is Meraki not looking into why this admittedly widespread problem came about in the first place and help us find a solution to the root cause of this change in behavior on the dashboard? And I don’t mean come up with workarounds. I mean find out what actually broke or changed in the first place and fix it.
New here

Re: Computer name not displaying properly in Description

This has been plaguing a couple of my clients recently. Although it should be a configurable option within the portal (if you are experiencing this issue please request this via the "Make a wish" button), I am leaning towards windows devices displaying MDNS names may be a software related issue. As mentioned by another user this could be a screencasting/sharing application. I picked two of my clients roughly the same size around 300 users per location. One has around 120 windows devices showing MDNS names, the other has 2. 

 

I will be running a comparison of installed software between these clients but unless the offending application is unneeded I am in the same boat as everyone else, trying to mitigate this egregious configuration on Meraki's behalf. 

Conversationalist

Re: Computer name not displaying properly in Description

We've been seeing this problem recently too (after never seeing it for years.)  I'm not expert but I'm thinking that since this problem began to affect people without Meraki's firmware changing, I think the common culprit might be something like the Chrome (and/or Safari) browser.

 

I believe the Chromecast uses mDNS/Bonjour so is it possible that when a user launches Chrome, the browser uses mDNS to search for any available Chromecast devices (to display on the cast tab) and Meraki is picking up the mDNS name linking it to the PC for the dashboard description?  Obviously, if this theory is correct, we all started seeing the problem after Google updated Chrome to some specific version...

 

Right or wrong, I agree that Meraki should allow us some control over the prioritization of protocols so we can have it ignore the mDNS transmissions and keep our dashboard clean and manageable!

Comes here often

Re: Computer name not displaying properly in Description

On MacOS , I was able to set the "HostName" on the device, as it was unset.   The command to do that is:

 

sudo scutil --set HostName <devicename> . (This command will set the HostName value.)

 

scutil --get HostName .   (This will show what HostName is set to.)

 

where the <devicename> is the name you want.

 

Other device names can be seen using:

 

scutil --get HostName

scutil --get ComputerName

scutil --get LocalHostName

 

Conversationalist

Re: Computer name not displaying properly in Description

Add me to the list as well. Submitted a case to Meraki on Jul 2nd about this issue and got the same spiel about it always being the case. It hasn't always been the case. In addition, I was told that if the name had been set in the Dashboard that the set name would take priority, but just today I note that Apple devices on one of my networks are now mDNS strings instead of the hostnames that I myself set previously.

 

Just one of the latest in a long string of mystery issues we have with the Meraki service that we don't have the power to prevent/correct (except in tedium), and that don't get the attention we deserve from support and 'engineering'.

Getting noticed

Re: Computer name not displaying properly in Description

JRLewis,

Thanks for the input. I haven't had any of my devices with manual descriptions switch to the mDNS strings, that's a new one. Hopefully Meraki support can come up with a fix or gives users the option to select what name should take priority in dashboard.
New here

Re: Computer name not displaying properly in Description

Same issue as everyone else, around the same time. Told the same thing from support, less than helpful.

I've made a wish request before (make the left side menu collapsible) super simple coding asked years ago. Still waiting.


Also found that Meraki MX devices with Meraki Switch reports incorrect usage. Told it's a known issue. Still waiting.

Really disappointed in Meraki right now. Going to dump them and ask for a refund. The only reason I'm with them was for the insights and reporting now I don't trust their devices and reporting. I can't support a security device that doesn't work on the simplest of requests. 

 

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.