Get Help broken?

Getting noticed

Get Help broken?

Has anyone else noticed the 'Get Help' link to the Meraki Support Center is about worthless right now?  The search doesn't work, navigating through the links takes you to broken 'Page not found' sites.  I've got their new documentation site bookmarked, just more convenient to click into the help menu and access it from there.  


I like the Meraki Dashboard for being an 'all in one place' tool, but not as helpful when it's not all in one place.

6 Replies 6
Kind of a big deal

It seems fine for me on n34 shard.


- Ex community all-star (⌐⊙_⊙)
Kind of a big deal
Kind of a big deal

N146 also looking fine.


possibly a browser issue @drgnslyr ?

Darren OConnor |

I'm not an employee of Cisco/Meraki. My posts are based on Meraki best practice and what has worked for me in the field.

Tried a different browser, same thing.  The main page of the support center loads fine, searching returns no results.  And since I am working on setting up our MDM, clicking the Systems Manager link, then the Configuration Settings link takes you to a "Page not found."


I'm on N68, not sure what difference it makes.

Kind of a big deal
Kind of a big deal

I can reproduce this issue on shard n85.  This is a job for @CameronMoody .




As a work around, go to the below URL.  It is working correctly.



I to have the issue on shard N70

Community Manager
Community Manager

Thanks for the report! I've sent this on to the dashboard team.


Caroline S | Community Manager, Cisco Meraki
New to the community? Get started here
Get notified when there are additional replies to this discussion.