Wi-Fi calling not working over Meraki AP

greaper
Here to help

Wi-Fi calling not working over Meraki AP

I have Meraki AP's connected to Meraki switches and have two SSID's configured.  One is guest and one is internal.  The guest network is configured for NAT mode with PSK and is only filtering Video and Music, no filtering on the internal network.  We are unable to make or receive any phone calls while connected to the wireless network.

 

I thought it might be a FW issue for the internal network but the guest network is not working either and it does not use our firewall.

26 REPLIES 26
NolanHerring
Kind of a big deal

Doesn't sound like your blocking anything specific to the protocols Wi-Fi Calling uses.

In my experience has always been a little finicky.

Sometimes it kicks it automatically after being on the call for a few seconds, sometimes it doesn't.
If I put the phone in AirPlane mode, sometimes it works, other times it says it requires a mobile network connection.

If you try it in airplane mode, does it allow the call to initiate? This is what I do to force it (when it works that is).

Also I'm assuming you have it enabled on the phone your testing with since it needs to be manually turned on first etc.
Nolan Herring | nolanwifi.com
TwitterLinkedIn

Wi-Fi calling is enabled on their smart phones as they say it works for them at other locations.

 

I will try to place a phone in airplane mode and see what happens.

Hi 

 

The best tip I can give you re Wi-Fi calling is to ensure that your mobile date setting on your phone is set to DATA only and NOT Voice + Data.

 

On an apples go Settings / Mobile Data / Mobile data Options / Enable 4G - Set this to Data only. 

 

You will also need to educate users so that they understand when talking on a call using Wifi calling, if they move out of range of the Wifi calling it will drop the call as it is unable to hook the call to the local mast in the area quick enough. 

 

Hope it helps

 

John

BrechtSchamp
Kind of a big deal

With phone calls you mean calls using the regular phone mechanism in cell phones right? So I assume we're talking about WiFi calling. I suppose calling works when you disable WiFi calling on the devices? Is this on Android devices or IOS devices? Are you experiencing this issue with all providers?

Yes, Wi-Fi calling using the regular phone mechanism on the cell phones.  This specific location is located in a basement that has very poor cell phone service.  I am being told that it is both IOS and Android devices but I will confirm that.  I can't specifically say right now if it applies to all providers but I will investigate that.

The problem appears to affect both Android and Apple and does not work even when the phones are placed into airplane mode.

 

Any other suggestions?

Are you blocking anything on the SSID side?

What firewalls are being used for corp and guest (since you mentioned them being different).

Something is blocking it if it doesn't work at all for any device.
Nolan Herring | nolanwifi.com
TwitterLinkedIn

The only thing being blocked on the guest network is video and music.  The firewall is a checkpoint firewall.  

 

I assumed that the guest networks traffic was tunneled past the firewall to the meraki cloud and would therefor not be subject to the firewall.  Is that not correct?

That is not correct. The cloud connection is an out-of-band management connection. Your user traffic is never sent to the cloud.

If the guest SSID is in NAT mode, it simply means that the AP is acting as the gateway, and will proxy. However the Internet based traffic, will still need to go out the CheckPoint firewall. If this is the only firwewall you have, then most likely, the firewall is blocking something there.

Check it to see if your blocking UDP 500 or UDP 4500
Nolan Herring | nolanwifi.com
TwitterLinkedIn

This also started affecting me today.  Some of my SSID's work for ATTWIFI some do not.

all are bridged.  I did not make any changes to the SSID but something else in MDM might have kicked .

we can no longer make wifi calls

Any one have and resolve this problem

Thanks

Squuiid
Here to help

Same issue with us. WiFi Calling just does not work over Meraki APs. Buyer beware.

 

I have had this problem very Recently, where Wifi  calling would be un predictable.  WiFi Calling sets up a type of VPN connection back to the provider.  so Content Filtering or any type of Firewall Rule that would block ipsec or anything blocking or Filtering port 500, 4500, 5061 will break wifi calling.  (For example with PFSense you have to Enable PF scrubbing). I have SSID with Internal NAT and my Wifi Calling is working.  Issue was my Router.

Is your Router a MX or another Device?

 

My issue was resolved by correcting an issue with the firewall and no change to the Meraki equipment. 

CharlesIsWorkin
Building a reputation

Would you explain?

cmr
Kind of a big deal
Kind of a big deal

It is normally the edge firewall that causes wireless calling to fail, we have the same on some of our networks.  The same APs on a different, but identically configured SSID work just fine when going through a different gateway firewall.

 

Haven't had time to fix it yet, but the firewall is where the issue will lie. 

Bossnine
Building a reputation

Is this due to a recent change?  I've been using wifi calling with Meraki MR42's for a year now (currently running 25.13) but have not heard of it not working anymore. 

Guess I'll investigate.

I had the same problem. I monitor port 4500 and packets flows and then suddenly i get disconnected. Sometimes i cant even place a call over Wi-Fi Calling. I contacted Meraki support but still no luck. My friend who is employed at Orange told me, the issues was at terminal side. I now trying for a 2 days Ruckus R310 and it seems less disconnection. Maybe it’s something is blocked at Meraki AP?

In my experience with wifi calling issue its always the Router.  The AP just passes Traffic Even in NAT mode.

My router is set to upnp, but I can control the traffic. Earlier last year I did notice such an issue, so it’s not a problem with router I think. Besides I setup on all my iPhones FastLane profile through MDM to ensure the voice and video has always highest priority. I don’t use Meraki router I use instead UniFi router.

Raj66
Meraki Employee

@Felippe Is the issue reproducible on demand? if so, I would recommend taking a packet capture on the wired port of the AP. Take a not of the time you got disconnect from wifi calling and check the frames for that particular time. This will give you some visibility if it is the AP or the router.

 

I suspect the issue is with the router but the packet capture will confirm the behavior.

 

cheers!

 

Raj

If you found this post helpful, please give it kudos. If my answer solved your problem, click "accept as solution" so that others can benefit from it
WagnerR
New here

This is likely related to your firewall, but here's why:

Apple WiFi calling uses a IPSec VPN connection on UDP port 500/4500 to connect the call, it's likely that your firewall is treating this traffic as normal and changing the source port during NAT.
You need to make sure that the VPN settings of your Firewall are set to preserve the connections.
Reach out to your firewall's vendor for assistance.

@WagnerR where would i be able to find this information for vpn settings? i cant do that in the meraki dashboard can I?

In my case it was my SonicWall firewall that needed to be configured to allow WiFi calling to work. It's not related to the Meraki Access points.

If you are having this issue I recommend you look into the VPN settings of your firewall, check if anyone using the same firewall has reported the issue and finally, reach out to their support team if you can't find the solution.

 

SmokeyMtnMan
Here to help

I know this is an old post, but wanted add some information to help those out there struggling. I have used Merak AP's for years and WiFi calling works provided its on an SSID that does not disable LAN access. For some reason, when you create a Guest network and diallow LAN access, wifi calling does not work. Web browsing works fine in this scenario. But on my internal SSID's, WIFI calling works without issue. 

I have not determined why the SSID's with Deny LAN block the Wifi calling, but its most likely related to a specific port or service on the internal LAN that is blocked by default in the Deny LAN Access of the guest network. 

Meraki equipment is great except for their crazy lead times to get new hardware.

Dudleydogg
A model citizen

Somehow the guest traffic must be blocking 

NFS and PPTP traffic. which is how wifi calling creates a tunnel, this is what I have in my notes, and I fixed the issue when I was using pfsense as my router 

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels