cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

VLAN & DHCP Issues: This device is using a DHCP IP address from VLAN instead of using config VLAN

Conversationalist

VLAN & DHCP Issues: This device is using a DHCP IP address from VLAN instead of using config VLAN

We are starting to roll out a Meraki installation for our remote stores. I'm working on setting up a switch now and I keep getting this error, "This device is using a DHCP IP address from VLAN instead of using configured VLAN 1." I have DHCP options set in the MX65 the switch is connected to but still no go. Below are some of my configs if you all can help, I'm new to Meraki. 

 

Management VLan setup on MX65mangementVLAN.PNG

 

 

Switch ConfigswitchConfig.PNG

 

 

 

 

17 REPLIES 17
Kind of a big deal

Re: VLAN & DHCP Issues: This device is using a DHCP IP address from VLAN instead of using config

Basically it's telling you that the static IP config you gave it doesn't work, so it fell back to using a DHCP address on VLAN 1 to reach the cloud.

 

https://documentation.meraki.com/zGeneral_Administration/Cross-Platform_Content/Behavior_during_Conn...

 

So something's wrong with connectivity on your VLAN 903. Verify that the ports you have connected are configured to carry that VLAN the same way on both sides. 

 

Also, if you're changing the Mgmt VLAN from 1 then you should be changing that in Switch-->Configure-->Switch settings.

 

https://documentation.meraki.com/MS/Deployment_Guides/Advanced_MS_Setup_Guide#Management_VLAN

 

 

Kind of a big deal

Re: VLAN & DHCP Issues: This device is using a DHCP IP address from VLAN instead of using config

Check the upstream port VLAN configuration as well. 

Adam R MS | CISSP, CISM, VCP, MCITP, CCNP, ITILv3, CMNO
If this was helpful click the Kudo button below
If my reply solved your issue, please mark it as a solution.
Highlighted
Conversationalist

Re: VLAN & DHCP Issues: This device is using a DHCP IP address from VLAN instead of using config

Which are you referring, the port on our MS210 or the MX65?

Kind of a big deal

Re: VLAN & DHCP Issues: This device is using a DHCP IP address from VLAN instead of using config

Conversationalist

Re: VLAN & DHCP Issues: This device is using a DHCP IP address from VLAN instead of using config

I have a couple times, but i checked again. I'm allowing all traffic on my trunk up to the MX65, and on the MX65 down to the MS210 i'm allowing all traffic. 

 

MS210MS210_uplink.PNG

 

 

MX65MX65_uplink.PNG

 

 

 I'm at a complete loss right now. 

BB
Here to help

Re: VLAN & DHCP Issues: This device is using a DHCP IP address from VLAN instead of using config

is it solved now?

Kind of a big deal

Re: VLAN & DHCP Issues: This device is using a DHCP IP address from VLAN instead of using config

@jhyoung09 For the switch static IP configuration have you specified VLAN 1? 

Capture.PNG

 

Also on that MX trunk port you may want to try setting a native VLAN of 1 instead of drop all untagged for testing.  You can always tighten it up after you get it working.  

Adam R MS | CISSP, CISM, VCP, MCITP, CCNP, ITILv3, CMNO
If this was helpful click the Kudo button below
If my reply solved your issue, please mark it as a solution.
Comes here often

Re: VLAN & DHCP Issues: This device is using a DHCP IP address from VLAN instead of using config

Did you ever find a resolution to this issue? I am having the same problem, but I cannot figure it out.
Getting noticed

Re: VLAN & DHCP Issues: This device is using a DHCP IP address from VLAN instead of using config

Hi! I have the same problem.

Here to help

Re: VLAN & DHCP Issues: This device is using a DHCP IP address from VLAN instead of using config

I would change the native vlan on both the side to match the management vlan

Just browsing

Re: VLAN & DHCP Issues: This device is using a DHCP IP address from VLAN instead of using config

Same issue here

New here

Re: VLAN & DHCP Issues: This device is using a DHCP IP address from VLAN instead of using config

same error here, nothing has changed (apart from maybe automated firmware updates) - what gives?

Getting noticed

Re: VLAN & DHCP Issues: This device is using a DHCP IP address from VLAN instead of using config

You need to configure both ports on the uplink for VLAN 903, if you want the MX, or any Meraki device, to use an IP on VLAN 903.  It's not going to be able to use a management IP on VLAN 903 if you don't have any ports configured for it.  It found an IP with internet access on VLAN1, (which is the default VLAN, or the same as no VLAN) so it used that.

 

This error is actually new(er/ish) in later versions of the Meraki software - it will try to find an IP if your settings don't work.  Which is what it's done here.  Before, in the older versions of the software, you just wouldn't get any traffic at all if it wasn't configured correctly.

Comes here often

Re: VLAN & DHCP Issues: This device is using a DHCP IP address from VLAN instead of using config

When configuring an IP address statically - don't put the VLAN in if the native VLAN is the same as the VLAN with the subnet you want to get an IP address from.

Getting noticed

Re: VLAN & DHCP Issues: This device is using a DHCP IP address from VLAN instead of using config

I don't have any problem with the setting that you describe, Fozzy.  My native VLAN is also included in the allowed VLANs and it's also the managment VLAN.  Static IP set on all devices.  It works fine.

 

Exception being switches from vendor XYZ we have connected to Meraki switches - if you configure the connection as a trunk port, the other vendor switch will not accept having a native VLAN on the connection, so we don't configure a native VLAN on those.

 

(Vendor XYZ not being traditional Cisco Catalyst switches, if that helps anyone)

Comes here often

Re: VLAN & DHCP Issues: This device is using a DHCP IP address from VLAN instead of using config

remove VLAN903 and leave it blank

New here

Re: VLAN & DHCP Issues: This device is using a DHCP IP address from VLAN instead of using config

Hi, 

 

Try the following; 

 

1) go to Switch Port,

2) click on the proper port 

3)  Edit

4) Allow VLAN -> Type the Vlan you need, if this is not clear, type "all" 

5) Save

6) Reboot the Ap 

 

Good Luck! 🙂 

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.