Meraki switch’s PoE issue.

Here to help

Meraki switch’s PoE issue.

6 of our switches lost all PoE capabilities 11 hours ago despite showing everything as working on the Meraki go dashboard. We have done all troubleshooting currently possible for us and still no PoE to devices or Cisco phones 


Internet is up and running no issue but still doesn’t provide PoE to devices.


What would be causing this issue? 

35 Replies 35
Getting noticed



Do you have any history of updates? There is another case of PoE going down during a similar period.

What is your GS firmware version?



If you found this post helpful, please give it kudos.
If my answer solved your problem, click "accept as solution" so that others can benefit from it.
回答があなたの問題を解決した場合、accept as solutionをクリックしてください。
Here to help

There is no firmware current it’s saying Not running configured version

Meraki Go Team
Meraki Go Team

We are currently investigating a firmware issue that affects PoE performance on GS switches. Please open a support case in the app and DM the case number to me.





We are having the same issue. Opened case number 09424332.
It started yesterday 03/16/2023. Unit is GS110-48P with firmware GS 15.21. Do you have an ETA on a fix? Thanks!

I've added your case to the support queue. Our support team will reach out with a resolution.

Thanks. I see now "Not running configured version" under Firmware. Can you update on the solution? Thanks!

Absolutely. The short term solution is a firmware rollback while we determine a longer-term solution. The rollback will restore PoE functionality.


The support team will contact you soon with next steps.

Great! I am assuming that your side will excecute roll back? What is the ETA on the process, and what version is the firmvare that I should see? Also, should I restart the device at some point or this will happen automatically?

Yes, our team will contact you and execute the rollback once you given them permission to do so. The device will reboot when the firmware update is complete. 

The rollback firmware version is GS 14.33.1.

Am still having and issue here is the case number 09418497

Thank you - I've added your case to the support queue.



Meraki Go Case 09427467

please fix it asap!

We've added this to the support queue. Thank you!

@JRS1 the team was able to update your firmware earlier today, and you should have PoE working normally. Just let us know if you're still seeing issues. Thanks again for your patience! 

Miriam Kung
Meraki Go Product Marketing

worked - thanks.
We still have one switch offline at the customer's, I'll get in touch as soon as it's back with us and we have to repair it as well.


best wishes from Hamburg

New here


I have exactly the same problem since 03/16/23 no port delivers POE on five GS110-48P all have also the firmware GS 15.21.
All my telephony is out of order. I need to find a solution urgently.

We have a resolution for this issue. Please open a support case and provide us with the case number (either here or via so that we can ensure that your issue is addressed.

Hey Art, we got a customer that's affected with this issue. I've just created a case number 09425285. Are you able to provide us with a fix ASAP? Since they've been down for quite a while.


Thank you.

I've added your case to the support queue and our team is actively working through the list!

I have open a support case with number 09429899, can i have a repons asap

We've added your case to the support queue. Thank you!


We have the same issue with a GS110-8P. Switch works, PoE doesn't.

Firmware is GS 15.21

Opened case: "Meraki Go Case 09426583"

I'd be happy to roll it back myself but I can't find that feature anywhere!

Thanks @jakster145, we'll make sure you're added to the support queue! They'll need authorization from you to rollback to the previous firmware version - the process is fairly quick and the switch will restart into the previous firmware version. 


cc @ArtMarshall 


Miriam Kung
Meraki Go Product Marketing

Thanks very much - just let me know how to provide authorization. I can do it now if you like.



Here to help

our switch has stopped working - no poe network down - is there a way to expedite this ?

Do you have a case number? The support team is working through these issues as quickly as they can. 

If you can share your case number, I can make sure that it's tracked against this issue.

Here to help

no, where do I submit the case?

Here is some information on contacting Meraki Go support 

it says i have an email account - but when i try the password reset doesnt send a reset link ? can you assist? is the email


@Stech we'll have someone on the team reach out to help you get logged back in + resolve your PoE issues. Many thanks for your patience! 

Miriam Kung
Meraki Go Product Marketing

thank you

@Stech it sounds like our team is having trouble locating your Meraki Go account with that email.


Would you mind writing into OR sending us a note through our form (here's the contact form link) so the team can dive in and help you get sorted out? Thank you! 

Miriam Kung
Meraki Go Product Marketing

ok, I've done that

no one reached out, this is still an issue - i have the switch off the rack and the serial number - but the app states that the email is in the system,but I'm not receiving any logon reset info.

@Stech thank you for contacting our team! It looks like the team was in touch earlier today - they'll follow up again from the info you provided to help resolve any issues. Much appreciate your ongoing patience. 

Miriam Kung
Meraki Go Product Marketing
Get notified when there are additional replies to this discussion.