cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Webhook stopped working

Highlighted
Here to help

Webhook stopped working

I am currently testing automated monitoring for our Meraki MX products. The API is great and the addition of webhooks is a warm welcome.

The webhooks have been working the whole day and spontaneously stopped working.

 

I have added my email address to the recipient (next to the webhook) and the mail is sent out fine for the alerts, just the webhook wont. It sometimes does happen that only some webhooks are triggered, but not all.

 

I know this is still in a beta phase, but any idea what could cause webhooks not being called?

4 REPLIES 4
Highlighted
Here to help

Re: Webhook stopped working

I have restarted the appliance, it seems this has helped for now.

But I would have assumed the mails, webhooks and snmp traps are handled by the dashboard, not the actual appliance?

Highlighted
Kind of a big deal

Re: Webhook stopped working

They are handled by the dashboard.  Restarting the appliance should have only been "co-incidental".

Highlighted
Here to help

Re: Webhook stopped working

I am getting bit weird response from webhook. We have few organization/network where webhook alerts is not working. Using the same webhook settings. The only difference is the URL we use to login to the portal. For example it's working for syd127.meraki.com. and mun155.meraki.com. but not for fra199.meraki.com.

 

I have tried manually invoke the wehbook using postman and interestingly the non-working is responding with 404 error.

 

FakrulAlamDA_0-1574463543477.png

 

 

but for the working one I am getting status as "enqueued". Do you think I might be issue with the region?

 

FakrulAlamDA_1-1574463628827.png

 

Highlighted
Here to help

Re: Webhook stopped working

Well apparently the issue is with special characters in organization name. Response from Meraki support:

 

"We currently have a known issue where special characters in an Organization or Network name will cause webhooks to fail, can you change the name of the Org from ****** SÜD to ****** SUD and test this again?" 

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.