MR33 - Access poin in repeater mode in meraki

Comes here often

MR33 - Access poin in repeater mode in meraki


One AP is showing in repeater mode. We haven't changed anything, Could any one please help me on this asap??

Thank you VERY much,


8 Replies 8
A model citizen

Check the cabling, patch port, switch port to the affected AP.  Have seen it where the AP is powered up and in Mesh mode but not able to operate as a gateway, turned out to be cabling that had degraded.  Try rebooting the ap before you do that

Comes here often

I have installed new MR52 access point in network and it came online as repeater, We have given static IP to it but it still in repeater mode.


We have rebooted , Factory Reset but still have same problem.


can you help here 

Kind of a big deal

If your access point is coming online as a repeater then it’s most likely it can’t get an IP address via DHCP on the Ethernet connection. So check to make sure the cables are good, and that your subnet/VLAN and DHCP are correctly configured (and that there are spare DHCP addresses available). I don’t believe configuring a static IP address will work if the access point is running as a repeater.

Getting noticed

@Lucifer  AP comes in repeater mode when it doesn't have the direction connection to the internet. Repeater mode AP could be a issue of bad cable, or bad power supply.


Sometimes rebooting the AP can fix the issue.

Kind of a big deal
Kind of a big deal

If you plug your notebook into the same switch port as the AP is in can you get to the Internet ok?

Kind of a big deal

If I may suggest an ordered troubleshooting list:


1. Identify the switchport that the AP should be connected to.

2. Verify the switchport's config. If it's good, continue on. If it's misconfigured, fix that!

3. Connect a known-good device to that switchport. Do you get the connectivity you expect? Assign a static IP address if necessary.

4. If the switchport is good, start changing cables one at a time in between the switch and the AP. Make sure you know these cables are good.

4a. If there's a power injector involved, swap that out too if you can.

5. If the switchport is not good, configure an empty switchport to match the settings. Check it using your known-good device.

6. If the new switchport works on your device, connect your AP back in. 

7. If AP comes up, victory! Otherwise, do steps 4 and 4a.

Building a reputation

I'm curious as to what the WAP is plugged in to. Most connectivity issues (working fine, then not with no change) with WAPs come down to a bad wire, a bad switch, or a bad WAP. I had one WAP that would randomly go to repeater mode and then back. Cable was fine, I re-tipped the ends, tried a different port, tried a different Meraki WAP, and always got the same result. I put a different brand WAP in place of it, and within a day I was alerted that the WAP had dropped down to 100mb from the 1000mb. I replaced the Cisco POE switch (SG300-28MP) a different brand of POE switch and haven't had a problem with that WAP since. Meraki does a bad job of defining why a WAP isn't functioning properly in many of these cases.


I've found that the model of switches that I inherited are junk, and have had 3 fail in the last month. Cisco reliability and stability ain't what it used to be!

New here

I have also seen this happen with the AP is coming online and downloading new firmware.   It correctly displays when the firmware was complete.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.