cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Wireless is real bad

Comes here often

Wireless is real bad

So I have inherited a system that consists of 7 MR66s spread around an RV park. Only one of them is hardwired in. The access points seem to cover very well and I can get a wifi signal from anywhere around the park. But the speeds are just awful. Getting 600 in from the ISP, everything running to the AP is gigabit. The top speed test I have ever had on the system is 45 mbps. The worst is below 1. I have tweaked around with the channel settings and controls to get a very slight improvement but with an average speed of around 10 mbps this just isn't a good enough system for the park. Any recommendations to help me out?

7 REPLIES 7
Head in the Cloud

Re: Wireless is real bad

Only one of them is hardwired in”

 

Every time a wireless AP acts as a repeater (any vendor) bandwidth cuts in half by definition. That and that fact that clients are likely far from the APs and devices can’t transmit back is most likely the issue. 

Get them wired or install some wireless bridges (being careful about channel selection) and make sure you have them located near the clients. 

Head in the Cloud

Re: Wireless is real bad

As Brandon stated one of the biggest issues you’ll be suffering from is the reduction in available bandwidth as you traverse each repeater. If you haven’t already seen the Meraki mesh document,

https://documentation.meraki.com/MR/WiFi_Basics_and_Best_Practices/Wireless_Mesh_Networking then it’s worth a quick read. The more gateways (i.e. wired access points) you can establish the better.

 

It’s probably worth also understanding the absolute maximum throughput put you’re likely to achieve. The MR66 is an 802.11n access point with dual 2x2 radios, each supporting two spatial streams. Although the data sheet states up to 600 Mbps this is highly unrealistic. Although 802.11n supported 40Mhz channels on the 2.4GHz spectrum they’re barely used and the later standards have deprecated this, thus your 2.4GHz will provide a PHY rate of about 72Mbps tops. On the 5GHz channel you might get a 300Mbps PHY rate if all the stars align - good signal strength, 40MHz channel, two spatial streams.

 

But these are PHY rates, the raw communication speed between the wireless access devices. The actual throughput of data on these will be anywhere between about 50% to 70% of this. So this is likely to be about 45Mbps on 2.4GHz, or 180Mbps on 5GHz - this is about 60%, with everything working wonderfully on a gateway/wired AP.

 

Take these bandwidths, spread them across all the devices trying to connect in the RV park (since wireless is a shared medium) and allow for the 50% bandwidth loss as you traverse repeaters, and you soon get to small bandwidths.

 

So what could you look at doing? You could make sure you’re achieving the best link speeds between the access points. With the APs you have this could be through 5GHz sector antennas pointing back to the gateway (check the link speeds between the APs in the mesh) - although that would then mean you’re looking to push people onto the 2.4GHz spectrum for connectivity. You could look at replacing the APs with more modern devices which provider greater throughput (you can use the same licenses, these are the same across the entire MR range). But ultimately the biggest improvement will be if you can get more of the APs wired in rather than using mesh.

 

Hope this is of some help, and good luck.

 

Edit: on re-reading this I may have been a bit unfairly harsh on 2.4Ghz. Technically with two spatial streams you could achieve 144Mbps PHY on a 20MHz channel, so a throughput around 85Mbps. But that said, I doubt you’d get a good two spatial stream connection on 2x2 under 802.11n.

Comes here often

Re: Wireless is real bad

Alrighty so I'm going to hardline at least one more AP in. I would like to do more but they really aren't set up in a way that would allow handlining of any more. It can be done but would require running line across the park. 

Also the top speeds that I am getting is being connected to the main gateway AP. Shouldn't I be receiving better speeds from that? I may test this on my own by just disconnecting the other APs. 

 

The client I am trying to do the speed test on is maybe 20 ft away from the AP with a clear line of sight. 

Kind of a big deal

Re: Wireless is real bad

@DCMHotels  What have you got set for per client bandwidth under your traffic shaping settings?

Meraki CMNO, Ruckus WISE, Sonicwall CSSA, Allied Telesis CASE & CAI
Comes here often

Re: Wireless is real bad

It was hard locked to 7 but I recently set it to unlimited. We only have a few people in the park right now though and I bet most of them aren't using the WiFi actively. The clients have capped out at 15 mbps in the last day so I doubt any user is using much at all.

Head in the Cloud

Re: Wireless is real bad

What client are you using to test the wireless? If the client is only a single spatial stream (or if it only connects using a single stream), then 45Mbps is pretty much all you’d expect if you’ve only got 20MHz channel width.

Comes here often

Re: Wireless is real bad

I have tested this on an IPhone xs and Oneplus 7t. I have also turned off 2.4 access to my test SSID and forced 5 for my devices with no success

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.