MS225 with SIP phones

Just browsing

MS225 with SIP phones

In our network we are using MS225 as a stack for 4 switches and MS-425 Stack as core. We have a call center for around 20 peoples running SIP phones hardware. Problem is those sip phones randomly start unregistering, lets say 2 phones at noon 12:00 and 3 at 05:00PM. I thought it was happening because of my DHCP server lease which is currently set as 4 days, but I'm not quite sure if it has anything to do with my DHCP.

I tried rebooting all those phones, turned off RSTP, Disable BPDUGUARD still the same. I never had this issue before in my network when I had Cisco 3750 switches. As soon as I deployed Meraki MS series switches I started facing this issue. I'm on MS 9.32 version.


Is there anyone else who is facing the same issue I'm facing?

Getting noticed

Haven't had issues with SIP PoE devices on 225's on any firmware level.


Checked the power figures and you within budget?


As an after thought... I did have 1 phone yesterday unregister.  The port status on the dashboard was PoE active but no link.  Did a cable test and came back with all 4 pairs with dashes which was a little odd...  Did a port cycle to no affect, ended up physically pulling the cable and replugging.  Assumed it was a bad cable...

Cable test is fine showing two pair since it's a 100Mbps connection, did power cycle change the port on patch panel and switch.

We have 10 phones on PoE and the rest of them are direct power same issue with all, it just happen randomly

What port range on the MS225 are affected?  All or 1-24 or 25-48? 

Kind of a big deal

Nope, never had an issue with any SIP phone rebooting on a Meraki switch.


Why don't you enable logging on your SIP phone and see what reason it is giving for rebooting.

It's not rebooting just unregistering for some reason which I haven't figured out yet. I rebooted all the phones thought that might be the issue still waiting for the agents to come up hey no service.
A model citizen

I haven't had this issue before and I'm running several 225's in my environment. What kind of phones are you using? I have Digium's in my environment.

Found this helpful? Give me some Kudos! (click on the little up-arrow below)

We have Avaya and Polycom.

We ran into this exact issue. Are they by chance Avaya J129's? After going round and round with the vendor, we learned Avaya J129's do this. If you contact Avaya, they will tell you it is expected behavior. We had to replace them with the next model up to prevent deregistrations. 

Head in the Cloud

We have MS225-48LP switches with software version 10.6 and Avaya 9641G IP-phones. It´s working well.

We connect the IP-phones to the switch, and the PC´s on the phones. The config is looking like that:


Bildschirmfoto 2018-02-23 um 09.54.43.png

access VLAN and voice VLAN configured.


Bildschirmfoto 2018-02-23 um 10.01.39.png



The phones are restarting when they loose the connection to the SIP-Server.

Can you check the Server Network connection?

Meraki Employee

I would definitely recommend opening a case with Meraki Support. Are there any logs at all on the phones or the Communications Manager that could be referenced? Do the phones seem to lose POE or simply just unregister? If it's the latter then the ideal way to troubleshoot this would be to perform packet captures near the switch where the CM is plugged into. 

Comes here often

Was this ever resolved.


I have a similar issue using Polycom VOIP phones connected to MS 225 access switches.


They have to communicate with a VOIP router on another floor and the traffic passes through a set of core MS 425 switches.


Phones on the same floor as the VOIP router all work fine. Phones on other floors that have to go through the core fail with a 'line unregistered' error. 

Getting noticed

We have NEVER had any issue with our SIP Polycom phones connected to our 3750 switches. Now we are having all kinds of issues with them connected to our stack of 4 MS250's. We are running into this issue now, and don't know what to do.

Are you running 802.1x with voice vlan on these ports?

There are known issues with the current firmware.

Kind of a big deal
Kind of a big deal

Which is fixed in 14.33 and 15.10

Getting noticed

Yes, but I wouldn’t asume he is not on stable, 14.33 is RC and 15.10 is Beta.

Kind of a big deal
Kind of a big deal

Indeed, just posting the fixed versions in case they are of interest.  Personally we run RCs from Meraki without a second thought, but are more careful with switch beta releases.

Head in the Cloud

We have got many Avaya SIP PoE phones connected to MS225 switches (firmware version MS14.32 and MS14.33)

SIP phones are connected to ports configured with voice-VLAN and client-VLAN, clients are connected to the SIP-phone.

No issues like that. only issue is that the phones sometimes reduce speed from 1Gig to 100MBit without any reason.

This issue is only observed on on 802.1x configured ports.


"The Voice VLAN fails to stay authenticated if it is authenticated before the Data VLAN (present since 14.28)"

Kind of a big deal
Kind of a big deal

14.33 is now a stable release so I'd upgrade to that if you haven't already?

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.