Config backup

Comes here often

Config backup

Hello there.


We are going to apply important changes on our Meraki MX100 (create some VLANS ) and I like to know if its possible to make a offline backup or run a rollback in case of something go wrong. Thanks.   

Kind of a big deal

@rulezzz Sorry but Meraki is 100% cloud based. You will just have to make a note of what changes you make.
Kind of a big deal
Kind of a big deal

you could prepare a script to undo you changes using the API. 


Meraki should make some kind of snapshot/save state where you can revert back to.

Kind of a big deal

@ww Sounds like the perfect idea for using the make a wish feature.
Kind of a big deal

I haven't used it for a while, but quite some time ago I wrote this script to doing offline backups/restore. 


What I would personally do is just copy the network to a new one.  Make the changes.  If you need to rollback just move the MX to the new network, and delete the original.

Hi Philip,


I'm trying to perform the backup via the script but i'm running into a problem.

First i had to go use Pycharm since in commandline it couldn't find the meraki-sdk, so using pyCharm fixed that issue. 

Now when I run the script with all necessary modules installed i get 2 errors:


Traceback (most recent call last):
File "", line 209, in <module>
File "", line 33, in get_org_id
result = meraki.organizations.get_organizations()
File "/Users/at-mbp-52/PycharmProjects/Meraki/venv/lib/python3.7/site-packages/meraki_sdk/controllers/", line 50, in get_organizations
File "/Users/at-mbp-52/PycharmProjects/Meraki/venv/lib/python3.7/site-packages/meraki_sdk/controllers/", line 94, in validate_response
raise APIException('HTTP response not OK.', context)
meraki_sdk.exceptions.api_exception.APIException: HTTP response not OK.


Any idea,

Already want to thank you for the script tho!



Kind of a big deal

Hi @Ahoste .  This means it is failing to retrieve a list of organisations that you have access to.


Are you sure the API key you are using is correct?


Does the API key belong to an organisation admin?


Hi Philip,

thank you for the reply.
The API key in the .merkai.env file is correct, this was my first thought too and I revoked the key and even created a new one but same error.


The API key does belong to an admin account with "organization" privilige.


Getting noticed

Kind of a big deal

The call to get the list of organisations is failing.  It's a pretty basic call that one.  It doesn't even have any parameters.


Are you sure the account being used is a Meraki organisation admin?

Are you sure API access is enable to the organisation?

Kind of a big deal

You could use the Meraki dashboard change log to reference what changes you made.

Darren O'Connor |

I'm not an employee of Cisco/Meraki. My posts are based on Meraki best practice and what has worked for me in the field.
Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.