IPad's iOS 14 or later version cannot be updated

Getting noticed

IPad's iOS 14 or later version cannot be updated

After iOS 14 was released, there was a problem with the iPad's status in the dashboard.
Even if 'Delay OS software updates' is not selected in 'Restriction', it has been confirmed that 'Enforced Software Update Delay: Yes' is set in Dashboard device's detail information page.
Of course, appears the software update has been delayed on the iPad's profile, and if I try to update the iOS on the iPad, it appears that there is no updated OS.


As a result of looking for the cause of this problem...
I know that in the MDM settings in iOS there are "force delay for software updates" and "force delay for software updates" settings. I expect the MDM functionality to have some changes in iOS 14 release.
If there is a history of setting the date of "Enforced software update delay" in SM with this change, there is a problem that there is no way to remove this setting.


It has been confirmed that other MDM vendors support setting these two functions separately.


As a temporary workaround, I set "Enforced software update delay" to 1 day and disable "force delay for software updates" so that users can update 1 day after iOS release.


Does anyone else have this problem?
Or, if you are having this problem, try my solution as above.

6 Replies 6
Kind of a big deal
Kind of a big deal

@Shany  SM currently only allows you to delay a user receiving OS updates it doesn't resrict it completely. I don't think its the end of the world if a user has an update notification they cannot clear. 


Apple releases updates often so updating is something we shouldn't be scared to do especially on an iOS device. 

A model citizen

I think I have a bit other problem with this setting.


A few weeks age I've activated the delay software update for 90 days, because of Xamarin Bug with iOS 14.2 & 14.3

And now the bug has been resolved with iOS 14.4 and I disabled the "delay software update" but the users still aren't able to update. Even when I push (force update) it seems like it doesn't work. This is affecting iPhones on my side.


As side note, some of my iPhones show on device details, they need to update to iPadOS 14.4 😄

Here to help

I opened a support ticket about this issue on 2/3/21, and it was acknowledged as a known issue affecting multiple customers. When I asked on 2/18/21 if there were any updates, I was told that they were still working on it, and there was not yet any ETA for a fix or workaround. Still patiently waiting...

Update:  We were notified by Meraki support late last week that this issue has been fixed, and we are currently keeping our fingers crossed, while we wait to see what happens when Apple releases their upcoming 14.5 update.

Getting noticed

Oh it's a good news.


I tried to test the post that the problem was fixed.

Even if 'Delay OS Software Updates' is not set, my iPad is always set to iOS updates to a 1 day delay

I have been disabled again after enabled this setting today.

The problem was solved as dfurasek said.


This can be checked directly in the Profile's Restriction pane in the iPad.


@dfurasekIf 14.5 update is released this month, you will be able to update immediately!

Thank you.


Here to help


I also have a ticket open with support on this, since Feb 10. They have confirmed it as a known issue. It wasn't a big deal until this weekend when Apply announced a vulnerability that is being exploited in the wild. Hopefully this issue will light a fire under the development team and they will get this fixed.


Kudos @Shany for the idea of resetting the delay to 1 day to work around the problem!

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.