Unable to Delete Orginization in Meraki Portal

New here

Unable to Delete Orginization in Meraki Portal

Help please, I am trying to Delete an Organization in the Maraki Portal and I am getting this error

Error! Failed with the following error(s): Cannot delete organization - it still has multiple users


I have deleted the network and also the appliance serial number, but still getting error


Thanks in advance

Thomas Haver 

5 Replies 5
Kind of a big deal
Kind of a big deal

hi @Hargray123 , have you removed all associated Administrators/Users on that Organisation?


Org > Configure > Administrators


Also look at


Network Wide > Configure > Users

Darren OConnor | doconnor@resalire.co.uk

I'm not an employee of Cisco/Meraki. My posts are based on Meraki best practice and what has worked for me in the field.

Thank you, that worked!!

It doesn't let me delete my own admin privileges - You cannot revoke your own organization privilege.  I need to delete several clients that either no longer use Meraki or are not managed by us.  Thanks in advance

Kind of a big deal

Yep, this is a problem I’ve come across too. You can’t remove yourself as an admin from an organisation, you have to get someone within that organisation to remove you - and support can’t/won’t help you here. The only way to do this is to reach out to someone in the organisation and request they remove you.


Just an FYI to others...  I hit this snag too.  The org had no networks, no devices, no licenses, and no other admins but me.  However I still got this error.


In my case, having SAML *enabled*, even though there were no roles assigned, was the problem.  Disabling SAML was the key.



Get notified when there are additional replies to this discussion.