No DHCP over vlan tagging

SOLVED
CESI
Here to help

No DHCP over vlan tagging

Hello,
 
I am trying to set up a ssid for TOIP. 
But when I connect a phone to this SSID, it doesn't get an IP back. 
 
I am using a Meraki MR44 and an Alcatel 6450 switch.
 
I already have an old AP1602i with the same port configuration.
 
Here are the configurations: 
 

 

 
CESI_3-1617022687164.png

 

 

CESI_4-1617022808034.png

 

Thanks for help ! 

1 ACCEPTED SOLUTION

Accepted Solutions
ww
Kind of a big deal
Kind of a big deal

Re: No DHCP over vlan tagging

If that dhcp discover is at vlan 100 you have to check on the switchport and /or at the dhcp server if you see that discover there also

View solution in original post

15 REPLIES 15
MarcP
Head in the Cloud

Re: No DHCP over vlan tagging

Firewall rule blocking access to local lan to receive an IP?

 

Wireless - configure - Firewall & traffic shaping

 

Tried it in bridge mode?

CESI
Here to help

Re: No DHCP over vlan tagging

Hi MarcP,

 

Thanks for your reply, here is my firewall configuration, normally everything passes. 

 

CESI_0-1617025641051.png

 

 

I have already tried in Bridge Mode but the problem persists 😞 

Inderdeep
A model citizen

Re: No DHCP over vlan tagging

Follow this document and check it helps you 

https://documentation.meraki.com/MR/Client_Addressing_and_Bridging/VLAN_Tagging_on_MR_Access_Points

 

Regards
Inderdeep

 

Regards
Inderdeep Singh
www.thenetworkdna.com
MarcP
Head in the Cloud

Re: No DHCP over vlan tagging

When you configure another port directly into vl100 and connect your notebook to it, do you get an ip?

 

Just to sort out a problem "behind" Meraki AP.

Is vl100 in your switch uplink to your Coreswitch/Firewall?

Is it working with the cisco classic AP? Connected to the same switch or another?

 

CESI
Here to help

Re: No DHCP over vlan tagging

I have an IP when I connect to the port with the default vlan 100. 
 
All the equipment is on the same switch and the other AP works well with my vlan 100 
ww
Kind of a big deal
Kind of a big deal

Re: No DHCP over vlan tagging

Start a packet capture on AP lan port.

Connect to the New ssid.

Open the capture

Filter on "bootp" and see if some dhcp traffic is tagged for vlan100. And what is missing

 

MarcP
Head in the Cloud

Re: No DHCP over vlan tagging

Can you show the config of your port?

otherwise I have no idea what can cause the problem.

 

Maybe @ww @cmr or @BlakeRichardson  have 😄 😛

CESI
Here to help

Re: No DHCP over vlan tagging

Hi ww !

 

I have DHCP Discover in the capture but I get no IP. 

 

I configured my port like this:

 

vlan 69 port default 3/24

vlan 100 802.1q 3/24

CESI
Here to help

Re: No DHCP over vlan tagging

But when I disable VLAN Tagging, I get an IP because I reach the default VLAN (69). 
 
So my DHCP is working fine, I don't know why when I enable VLAN Tagging, DHCP doesn't give me an IP. 
ww
Kind of a big deal
Kind of a big deal

Re: No DHCP over vlan tagging

If that dhcp discover is at vlan 100 you have to check on the switchport and /or at the dhcp server if you see that discover there also

View solution in original post

cmr
Kind of a big deal
Kind of a big deal

Re: No DHCP over vlan tagging

@CESI Is the DHCP server directly connected to VLAN 100 or is there a DHCP helper entry on the routed interface/default gateway of VLAN 100 pointing at the DHCP server?

CESI
Here to help

Re: No DHCP over vlan tagging

@ww 
I did the test, by putting a port in vlan 100 and connecting directly to it, I get an IP. 
 
In this case, the DHCP server is directly in vlan 100
MarcP
Head in the Cloud

Re: No DHCP over vlan tagging

Did you already contacted the support as well? This sounds really strange.

 

Another AP tested? 😄 Maybe yours is faulty 😞 Don´t know something else.

CESI
Here to help

Re: No DHCP over vlan tagging

Yes, I think I will contact the support.
I have only one AP 😞 I hope it is functional 😅

CESI
Here to help

Re: No DHCP over vlan tagging

It works!
So I tagged my two VLANs and did the same on my SSID's

But the first time it didn't work.

 

Thanks for help ! 🙂 

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.