Access point has an ethernet negotiation failure

ATS55
Here to help

Access point has an ethernet negotiation failure

Hello everyone,

I receive a message on Alert Hub that says "Access point has an ethernet negotiation failure" and it shows me the APs name related to this error message. My APs are all MR33, but only 4 APs are added to this error message.

Anybody has had the same issue?

Any comments?

 

Thank you

40 REPLIES 40
RaphaelL
Kind of a big deal
Kind of a big deal

Have you seen any link negotiation issues on your switch ?

Macguy
Getting noticed

I just saw 8 Access Points on my Alert Hub with same message.  Various AP models along with both Aruba and Meraki switches.  Tried forcing 1Gb Full Duplex (didn't work) on switch.  I'm going to try and get to one of the buildings tomorrow.  Upon looking at port history, seems like this ethernet negotiation has been an issue.  Maybe this alert setting was just added to the Alert Hub?  Not sure.  Will post follow up tomorrow.

PhilipDAth
Kind of a big deal
Kind of a big deal

What is the AP set to?  auto/auto I hope?

What is the switch port set to?  auto/auto I hope.

 

What speed and duplex are they reporting?

If you have a Meraki switch, do a cable test.  What does it report?

In my case Auto for both... Cable tests pass on Meraki switch.  Reporting 100Mbps, should be 1Gbps.  I'm going to do more testing tomorrow. 

ATS55
Here to help

In my case the ports on the switches are set to auto negotiation. They passed 1 Gigabit and now they are passing 100 Megabit. I restart one of the APs and it didn't help. The issue is happening on different locations (of course different switches, too). Now, I have the alert on 8 APs. It seems the issue is spreading.

TBHPTL
A model citizen

You can't set speed and duplex from one side it has to be set the same on both sides. auto/auto or hardcoded same on each side

 

As @PhilipDAth stated:

 

"What is the AP set to?  auto/auto I hope?"

"What is the switch port set to?  auto/auto I hope."

I have checked that on the AP's local configuration (through my.meraki.com) and Meraki dashboard setting, but I didn't see any where I can change link speed. The only setting I'm able to change is on switch port setting. I will be happy if anybody shares their info where we can have access to the setting @TBHPTL mentioned.

TBHPTL
A model citizen

Macguy
Getting noticed

So this is super weird.  Went to my elementary school, took AP negotiating at 100Mbps down.  Plugged into my Mac laptop and instantly got connected at 1Gbps.  I grabbed a spare MR46 and plugged that in with same cable.  It connected/negotiated at 1Gbps.  Left MR46 in classroom.  Took the MR56 down to my IT office and connected to port on desk (connected to different Meraki Switch) and negotiated at 100Mbps.  Going to open case with Meraki as it seems in my first example here it is the AP not cabling.  I have seven more AP's like this to diagnose. 

 

UPDATE - On phone with Meraki support and before doing an RMA we decided to do a factory reset on the AP.  Sure enough, the AP remained stable and connected at 1Gbps after.  I'll post updates with the other AP's accordingly.

Having the same issue on four MR46 and MR52 access points.  I can confirm that factory reset has fixed three out of the four.

regz20
Comes here often

Where do you initiate a factory reset? Meraki or to the switch port? 

There's a reset button on the access point itself.  It's usually next to the network port.  You'll need something pointy.  Leave it powered on, press the reset button for 5 seconds, it will reboot and reset.

Bill6
Conversationalist

We are having the same problem as OP

RaphaelL
Kind of a big deal
Kind of a big deal

We have 5K MR33/MR36.  Actually 55 of them are negotiating at 100Mbps. However , all my cases are related to bad cabling ( did a cable test on every single one ). 

 

So, have you tried doing a cable test as suggested by Phil earlier ?

randyjackson197
Just browsing

We are also seeing this suddenly.  We are running firmware 30.5 om MR46 WAPs.  Could this be a firmware issue?

Mine are on MR29.5.1

Don't think so... I have 29.5.1 and 29.7 with various AP models. 

Los míos son MR 29.6.1 Modelo MR46E

Reseteando el SW Meraki tb, algunos vuelven.   

Aunque el test de cable indicaba falla, los cables fueron certificados, probaremos ahora reestableciendo los AP que mantienen los inconvenientes.

Bill6
Conversationalist

I opened a ticket and was told this is a known issue and our ticket was added to the list.  I would recommend anyone having this issue do the same.  It was recommended to us that we roll back to the version 28 firmware, so Merakii did that for us and I haven't seen the problem since.

Macguy
Getting noticed

Thanks for update.  I posted question to my ticket asking about the "known issue".  Not cool since 29.x fixes many issues we were having. 

I would recommend anyone having an issue open a Support case and not make any assumptions based on this thread. I checked the case mentioned below and it's not tied to any known issue around eth speeds on APs. The APs in that case show event log messages that point to another problem not eth speed related.

Macguy
Getting noticed

What is your ticket number?  My support tech just responded that he is "unaware of any known issues".

Bill6
Conversationalist

We have opened Case 10853438 for you.

Macguy
Getting noticed

Just factory reset (3) MR56 AP's at my middle school all successfully negotiated at 1Gbps.  Really wish you could factory reset remotely via GUI under tools.  So far 4 out of 8 have been fixed with factory reset.  I'll deal with the 4 next week. 

ATS55
Here to help

As I have tested that on 2 of my APs so far, I found that we have connection issue on pair 3 and/or 4. I resolved the issues and the link speed changed from 100Mbit to 1000Mbit / 1Gbit. then the alerts for the two APs have gone. We had the link speed up to 100Mbit before, but Meraki never alerted us for that. It seems Meraki is stepping up to introduce higher than 1Gbit link speed.

Macguy
Getting noticed

So last night I was messing with the remaining four AP's reporting 100Mbps.  All I did was run a cable test on an MR56 and everything passed.  Few seconds later the dashboard reported 1Gbps.  I did nothing else.  This is an AP that has been rebooted too.  There are 3 AP's remaining in my environment and one appears to be cabling.  I will factory reset the other two. 

The thing is if you connection problem (layer 1), sometimes cable test or rebooting the device help. I have had the experience. But in my cases I had a serious connection issues.

ponzcruze
New here

Having the same issue on four MR46 and MR52 access points.

SecurityFinance
Comes here often

Yes, we have about 800 AP's and all the sudden on Sept 27 at 18:32, about 38 of them all alerted on this issue. Bounced the port to reset them but still showing alert and syncing at 100Mbps. Meraki terrible support just acts like, ah, well, upgrade the code on them and see what happens. The other shotty tech wants us to go to them and factory reset them. Who's gonna pay to send a tech in to every locations affected and take the AP down from ceiling and factory reset them. You can't find anyone worth shooting these days. Aggravating to say the least and I hope it don't keep spreading to the rest of the AP's.

I think what happened is they added this new alert to alert hub.  The issues with 100Mbps were probably already there.  But yes, physically going to each AP is annoying.  I really wish they had a remote factory reset option in dashboard.  We have 600 AP's and only 8 had this issue.  Don't think this is a firmware bug. 

antonis_sp
Building a reputation

Fun fact, this has popped up on all the APs of one of our customers.

All APs have 100Mbit connections as they are connected to FastEthernet ports.

 

Waiting on support.

pjc
A model citizen

Yep, same here, hundreds of our AP's are reporting this error this morning, logged with support

 

Access point has an ethernet negotiation failure

pjc
A model citizen

Response from support including workaround.  That's teach me to opt in to new features....

 

Thank you for contacting Meraki support.

We are currently aware of a issue that is causing false positive alerts due to a on-going issue that is being investigated with high priority. As a workaround please disable Opt-in to view and manage alerts in a new centralized Alert Page on the early access page until the issue is resolved to clear the alerts shown.

Once we have confirmed that the issue is resolved we will provide you a update.

antonis_sp
Building a reputation

Got the same answer. Workaround is working for us.

Macguy
Getting noticed

So in my case I did a firmware update to one of my middle schools this week and all of a sudden two AP's negotiated at 100Mbit (they were full 1000Mbit before upgrade).  I got same alerts via org - alerts about negotiation failure.  All I did was do a cable test on Meraki Switch and they magically negotiated at 1000Mbit.

We had the exact same issue last night. Around 10pm GMT, 60 of our APs triggered offline alerts.  It doesn't seem to be service impacting but at least it has flagged APs not negotiating at 1Gb.

We have a ticket open with Meraki, but appreciate the helpful updates you've all posted this morning.

Same issue here with 11 ap's that connect to a 100mbs switch port.  Glad to hear it isn't just me!

RyanS1
Conversationalist

Not that this helps, but I had some access points and also had a couple switches say they were offline, but they really weren't.  I turned off "opt-in to view and manage alerts in a new centralized alert page" under Organization - Early Access.  It all went away and back to normal.  I think it is just an interface issue and nothing really wrong with the equipment.

Same here, i turned this option off and on again, all the "Packet fragments detected" (switch) and "Access point has an ethernet negotiation failure" (access point) went away.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels