DHCP issue

Getting noticed

DHCP issue

I'm hoping someone may have seen an issue we are having, or perhaps be able to help.

We have MS410 switches running DHCP with dual uplinks to MS225s across a number of floors.  We are running separate wireless and wired vlans on each floor.  DHCP is working for all VLANs expect for one wired vlan.  One device has been given a dhcp address some time ago, and continues to renew it's lease, but subsequent attempts are failing, with no IP address being assigned.

Any devices given a static IP address within the DHCP scope connect without issue, the DHCP scope is hardly used so the scope is not full.  The DHCP settings match the other scopes that are working correctly.  It is as if the DHCP server is offering an address, but not getting a response from the client, but the same client will receive an IP address on any other vlan.  I've tried making, and reverting, a small change to the dhcp settings to try and give the scope a kick - grasping at straws.


Any suggestions or observations would be much appreciated.

11 Replies 11
Kind of a big deal
Kind of a big deal

Check your DHCP server policy.  Maybe it is set to block DHCP by default and the MS410s have not been authorised for that VLAN.



Perhaps trying turning DHCP off and on again for that VLAN.


You could also try plugging a machine directly into the MS410 and see if it can get a DHCP address.



Thanks for the reply.  The default policy is set to allow dhcp servers.  Unfortunately our MS410s only hves fibre sfps, and no spare ports to plug a new device into.  But I will certainly try stopping/starting dhcp for the vlan.  Thank you.

Kind of a big deal
Kind of a big deal

Have you tried running a packet capture to see if there is anything out of place? 

Thanks for your reply, we intend to give that a try when we have some available tomorrow.

We ran the packet capture yesterday and can see the DHCP discovery packet being generated on the MS225 port and being processed by the Ms410, but then the process stop, there are no further dhcp packets from the MS410. I've raised a support case on the back of this.  Thanks for your help

A model citizen

So you configure an access port for a vlan and you get an IP. You then reconfigure said port to the problem vlan and you get no IP?


The 410 is the layer 3 switch and running DHCP? 225 are just layer 2 switches south of it?


yes that is correct, configure an access port for all other vlans works ok, but the trouble vlan doesn't give an IP address.

and yes 410 is the layer 3 doing dhcp with uplinks to a pair of ms225s


Apologies I marked this as a solution rather than hitting reply

Getting noticed

If the port already assign as access port for certainly vlan, it should no problem to the device connect to that port, what about on the router? already assign dhcp server to the certain vlan?


Thank you

Getting noticed

Thank you, yes DHCP is setup, and has worked for one device in the past. The port is setup as an access port, and a statically assigned address in that range works when connected to the port, it just doesn't give DHCP

Getting noticed

- Just make sure that this particular vlan is appearing everywhere from MS410 to the device (trunk ports, access ports)

- No special access list are configured


Packet capture to confirm DORA steps of DHCP should help to see what is going on

Comes here often

What MS firmware do you have installed on the switch? 

Get notified when there are additional replies to this discussion.