Catalyst 9300 Meraki onboarding - Authorization issue

New here

Catalyst 9300 Meraki onboarding - Authorization issue

I am looking to onboard a Catalyst 9300 into our Meraki dashboard to check out the monitoring mode. Running through the onboarding application presents no errors and onboards "successfully", however in the dashboard we are only seeing basic reachability and no telemetry or even port status. 

Watching the terminal of the 9300 we are seeing an authorization error in regards to the Meraki-user and the use of Netconf (%DMI-5-AUTHORIZATION_FAILED: Switch 1 R0/0: dmiauthd: User 'meraki-user' from [Meraki IP] was not authorized for netconf over ssh.).

Can anyone provide insight into whether or not this is responsible for my lack of data and what steps I may take to correct this or point me in the right direction?

Any help is greatly appreciated.



3 Replies 3
Kind of a big deal
Kind of a big deal

That would be your issue. The Meraki dashboard logs into the device via Netcong (over SSH) to pull data.


What does your running config look like?

Did you have existing config on the switch before integrating it with the dashboard?

What privilege is the Meraki user account configured for on the switch?

Do you have ACL's set up for SSH?

Kind of a big deal
Kind of a big deal

Hi @sellington 


Are you following the guidance on how to onboard from here:

Darren OConnor |

I'm not an employee of Cisco/Meraki. My posts are based on Meraki best practice and what has worked for me in the field.

You've probably solved this by now, but for anyone else that also didn't read the fine print like me and wasted some time.


Radius authentication from a switch is not a currently supported feature.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.