Verizon 730L and MX64

Getting noticed

Verizon 730L and MX64

I have been rolling out MX64 to remote unman sites with Verizon USB730L as failover. I have come across issue where they do populate fine on laptops and work. But recently purchase Meraki MX64 , are have been having issue seeing any these modems. The modems do turn on and with both LED light to green but not seen in dashboard.


I tried different firmware version to include beta, still same issue, i have had verizon assign static ip to these devices.

At one point I thought it was an issuer with the 730L due to the being refurbished, we also purchased and upgraded to newer version 730L with the same issue.


These meraki came from 2 different vendors, but same issue. Is there a current issue and do i need to use different USB modems other then verizon 730L. We have some working in production though.


Enterprise user here - Have 500 of these in the field and ran across the same issue.



Per Verizon - 


“The 9030 is end-user mode. And 9031 is lab test mode. 9032 is enterprise mode. Devices should never be in 9031 as that is a PID that is purely for us.   Plug the device into a PC, open a web page, navigating to, you should be to able to change back to End-user mode.”

View solution in original post

Kind of a big deal
Kind of a big deal

Does the dashboard report that the USB modem is plugged in?


Does the USB modem have any firmware updates from Verizon?

dashboard doesn't report of any usb modems, i have tried multiple new verizon usb 730L that we have purchased thru verizon. Although the usb modem does turn on when plugged into meraki. not able to ping the USB static public ip that is assign per request thru Verizon.


I checked USB firmware by forcing update thru the my.usb portal   via a laptop. Only firmware availble i belive is from 2017

Note that the USB modem is not bought online until the WAN circuit has failed.  So you wont be able to ping it if the main Internet connection is working.

affirmative, WAN is disconnected


We have started since some issues like these recently since deploying more then 20 mx64s

Per case I need to identify USB 730L that need to have device ID of  1410:9030 for mx64 to work with them, but this device id could be older version or certain version of the 730L.

Building a reputation

I noticed on the Meraki sported modem page there is a * by that modem with the following warning * Requires connecting the MX to the cloud to download the latest cellular modem definitions 


You had me scared as my older Verizon USB620L is no longer listed, so I tested and it worked perfectly. Question: Does the MX work without issue on a copper WAN connection? IF so, you said it never shows a cellular device as connected while on a wired WAN connection and the USB modem plugged in correct? Do you happen to have a cradlepoint or like around you can test the SIM in? 

If the above are true you coudl try a factory reset on the MX.

@Cmiller The 620 is listed toward  a second part of the list in the end of sale section . To my understanding the the 620 will not work with meraki made after 2017 , I think


I connect the wan to to the 730 because it needs to connected first that for first initialization per modem the link should, which is the one I been following  for a while and it was linked to me by the support case that was opened about this issue.


I have a bunch of cradle point laying around because that is what the mx64 are replacing. Cradle point are great. We are trying to minimize  network equipment at remote non man sites.

Building a reputation

I am using CradlePoint as a backup on WAN2, then use WAN1 as a primary  w/o load-balancing.

Getting noticed

The issue has come down that the older version of 730L used USB ID or hardware ID of 1410 9030 and the current new 730L are using 1410 9031, which for some reason isnt supported by meraki mx per documentation.


you can pull the usb using linux or i used the device manager and thru hardware id and you see the info of the USB modem. As of right now there is no time table as to when these will be supported via firmware per support.

Raise a support tickect with that info.

Did already nothing can be done per support on this issue and that i need to use the  specific USB with that specific USB ID.

I tried for weeks to use 730L with MX64s with no luck. The solution was to switch to 620Ls. Seems like it's hard to find 730Ls with the Meraki supported USB ID.

Currently it is a hit or miss with finding 730L with specific USB ID. The only one that are not bound by specific USB ID are the Pantech UML 295. There might be other but our is Verizon.

We are having the same issues - on the Meraki Support page they say they support the USB730L modem with a USB device ID of: 1410:9030 - the new ones come with an ID of 1410:9031


Meraki support is telling us that is why they are not being detected, we're trying to get them to allow that ID to be picked up with the same driver


This issue doesn't matter the version of MX, We're seeing the same problem from MX64 to MX65 to MX84

@tomas209ca  i used the device manager and thru hardware id and you see the info of the USB modem


Can you elaborate on this for me?  I have many USB730L deployed remotely and I would like to know which card is in each of my MX64w.  I need to obtain the SIM, device ID or phone number for each of the USBs.  Thank you!

As for SIM, phone number, IMEI, I got the info from the Verizon Business account that our company has.Or if they he other site are close to you, you can go to them and get the info by plugging them into the a computer and http tot he gatewya ip of the USB. Currently have about 33 deployed to sites.  As for the Device ID, i had to actually plug it into the computer to get that number. As for IP this will depend if you have static ip to them or not. You have to pay a one time fee to get these public ip allocated to you. This has to be done on the verizon side. The static ip come in hand if you need to do port forwarding.

Enterprise user here - Have 500 of these in the field and ran across the same issue.



Per Verizon - 


“The 9030 is end-user mode. And 9031 is lab test mode. 9032 is enterprise mode. Devices should never be in 9031 as that is a PID that is purely for us.   Plug the device into a PC, open a web page, navigating to, you should be to able to change back to End-user mode.”

This is what is needed to be done for those that receive 730L that will not work with you MX security appliance.

Also if you don't now what the ID is , you can go to device manager and look for Remote NDIS Compatible device.
From there you can go to event tab and it will give you the info on the PID or you can got to details>hardware Ids.

I think also those that are on 9031 show up as RREMOTE NDIS Compatible device#2, i believe.

@tomas209ca Thanks Tomas.  I guess my question is: Is there any way to obtain the USB information from the MX64 or from the meraki dashboard?  

as of right now not that i now, unless you can pull it from mx API. Only time i am able to get data from the usb modem is when it fails, and the only thing is either on the uplink info or appliance status. Also maybe in the Event Logs also. I do recall opening a case and i think Meraki tech might be able to, but not 100% sure though.

Kind of a big deal

One thought would be to use an unlocked usb modem that supports Verizon, possibly it will work. I am not sure this one will work, but it might be worth a try.


I do know this works on MX devices with T-Mobile Sim cards.

Here to help

We had horrible problems with the 730L and our Verizon carrier.  We are using Z1 and Z3 merakis and have several sites running cell only connectivity.  We have many out there running on old Pantech modems, working great.  The 730L is listed as a compatible modem on the Cisco Meraki compatibility page, but that was not our experience.  Many network drops, often hours at a time...not good for production law enforcement connection.  We have to hunt and peck to find the ancient Pantech modems, and they work fine.  


I opened a case with meraki support and went through several techs, and all were stumped.  And I think the 730L works ok for some areas and folk, but here they've been so sporadic it just is a no-go modem for us.  Hopefully the Z3C comes down in price and be a bit more viable for some site budgets.

Getting noticed

I purchased about 7 to 8 new 730L from verizon and they didn't work. Also tried setting them up to end user mode, but that didn't help either. I ended up re purposing UML 290 or 295 modems, they been working without issues. I just been using these modem for MX64 that are in remote area for emergency failover.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.