MX450 Internet Connectivity - Need Help

Getting noticed

MX450 Internet Connectivity - Need Help

Hi All, 

I am with cusotmer implementation where, we have 1Gig internet link needs to be connected to MX450 which will have SFP slot,,for that we had brought SFP(MA-SFP-1GB-TX) which we had installed in MX450 INternet slot..,

But when we can the lan cable from the ISP rotuer to the Internet port of MX450(on top of SFP) we are not seing any LED's on port.., 

do guys think any compatble issues with SFP ? we go this modile based on the meraki SFP sheet and we do have confirmation from Meraki as well that it should work.


Any suggestions please we need to install this MX450 by tomorrow.

Kind of a big deal

That should work fine.


Have you tried a different Ethernet cable?


What happens if you connect your laptop to the ISP port?  Do you get activity then?  Has the isp confirmed that their port is up?

Darren O'Connor |

I'm not an employee of Cisco/Meraki. My posts are based on Meraki best practice and what has worked for me in the field.

yes..,I had tried changing the cables no luck. ISP is fine...i can able to browse the internet when i connect to ISP cable to laptop

Kind of a big deal

I know there were some recent incompatibility issues with recent MA-SFP-1GB-TX modules and some of the firmware versions, can’t remember which though - have a look through the release notes and see.


If this is the problem, the next issue is I don’t know how you can update the firmware on the MX to support the SFP, if you can’t connect the MX to the Meraki cloud - because of the SFP issue.


Do you have an older MA-SFP-1GB-TX module or even a Cisco GLC-T, or a third party module that you can use to try and get it working?

Getting noticed

unfortunately i do not have oldver version of SFP-TX, can we connect Internet link on any  of the SFP(of SFP+) other than Internet ports ?



Kind of a big deal

@hianilz, the MX only connects to the Meraki cloud via the WAN (internet) ports. You can try either of them to see if it works. If you don’t have another SFP to try then your only option is going to be calling Meraki support. They should be able to tell the version of firmware on the MX, if it’s the compatibility issue, or if it’s just a faulty SFP module.


You can also check the local status page on the device, it might provide you some hints (like if the WAN port has been forced to 10Gbps or something). It’s worth a try.

Building a reputation

This bug has been fixed as of MX Version 15.44.


Bug fixes

  • Resolved an issue that resulted in MX250 and MX450 appliances being unable to properly utilize some MA-SFP-1GB-TX SFP modules.

You are in a chicken or the egg scenario where you need to upgrade the MX to 15.44, but can't get their because you can't connect the MX to the internet.


Your best bet is contact Meraki support and they can probably send you a new copper SFP.

Thanks for all your advices. Issue has been resolved. I hadconnected below scenerio and was able to upgrade the MX450's to 15.44 and it has started detecting the SFP for copper.


1. I had connected internet copper cable on one of the switch(MS350) port(copper)

2. From the same switch(MS350) port 49(Fiber slot) I had ran the fiber cable to MX450 on Internet port with SFP(SX)

3. As soon as I second step it has started detecting it is SX it's own slot of Fiber.

4. I had confugured the IP address on MX intial page and it has started connecting to Dashboard and downloade the firmware.

4. Once the device is on 15.44 then i had connected back to my original scenrio and it started detected and i can the access the device in dashboard.




Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.