Clear DHCP leases - MX84

jvelasco
Here to help

Clear DHCP leases - MX84

Hi, 

May I know if there is a way to clear out the DHCP Leases in a certain VLAN?

I configured static IP addresses but their previous addresses are still there in the dashboard. 


Thanks!

26 REPLIES 26
PhilipDAth
Kind of a big deal

I don't know the answer.  You could try turning DHCP off and then back on again.  

 

I believe as soon as the client disconnects and reconnects to the network it will go through the DHCP process again. At that point they will receive the newly assigned static address. If they try to renew the lease I think the DHCP server will refuse and assign them the static IP address too.

Hi Brecht,

I have tried it but it seems it does not work 😞

Every time I'm in a situation where I need to clear a DHCP lease on Meraki, I hit this button so hard...

meraki-maw.PNG

There is no way (that I know of) to clear a DHCP lease manually in Meraki. Best is to lower lease time, in the DHCP server, and wait for the leases to renew, to the shorter lease time. 

Hi,

I think that is the "wish button"?

Well, I will check your suggestion. Hopefully later on the update, they will have that feature.

@rbnielsen 

I just made a wish too. 🙂


@jvelasco wrote:
Hi Brecht,

I have tried it but it seems it does not work 😞

Hmm well that's annoying. Good to know.

Thanks for the tip 🙂 I will try it now.


@PhilipDAth wrote:

I don't know the answer.  You could try turning DHCP off and then back on again.  

 



This has worked for me in the past.  After you turn off DHCP for that subnet, wait about 5 minutes, then turn it back on.  When you turn it back on, all your previous settings are still there so it's not as painful as it seems.  

 

Not optimal, but it works.  

Hi Todd

How do I turn off Dhcp for the subnet?

 

Thank you

rbnielsen
Head in the Cloud

Security & SD-WAN -> DHCP

 

rbnielsen_0-1622535052783.png

 

This has worked for me in the past. After you turn off DHCP for that subnet, wait about 5 minutes, then turn it back on. When you turn it back on, all your previous settings are still there so it's not as painful as it seems.



Not optimal, but it works.
Ben
A model citizen

Set the DHCP lease Time to 30 minutes in the evening when everyone leaves and wait.. That's how I handle this. 

 

Cheers 

Ben

Hi,

I've done two options, setting it at 30 minutes and then reboot.  At last, it renews all leases. 

But I think the Cisco Meraki must do something about this because it is really important. 


Thanks.

wh00ps13
Conversationalist

Looks like they patched that out? 

We read your comment and decided to try it. We were joking that only the new leases would get the shortened lease time. We thought that was a hysterical idea. Then it turns out that's what happened. A lot less funny than we thought...

KMNEP
Getting noticed

is there any development going on for this issue? Manually changing dhcp leases to 30 min at the eod is not the ultimate solution. I hope there would be a select and delete option somewhere for removing dhcp leases.

It seems like every time I look up how to do something in Meraki, the answer is you can't.  Why do people sell this junk?

AlexC
Meraki Employee


@jvelasco wrote:

Hi, 

May I know if there is a way to clear out the DHCP Leases in a certain VLAN?

I configured static IP addresses but their previous addresses are still there in the dashboard. 


Thanks!


Hi @jvelasco,

 

A 'button' to clear DHCP Leases from dashboard is certainly a feature request at this time point in time as others have commented.

 

However, there is a way to clear the DHCP Leases on a VLAN without having to reboot the appliance by following these steps:

- Create a DHCP Reservation on the VLAN that blocks out the entire DHCP range

- Save the configuration and let MX downloads it (might take a minute or two)

- Clear the DHCP Reservation and save the configuration again

 

Hope this helps, if you are still having trouble, I would recommend reach out to support (that's whom I got this info from). You can find support information from dashboard under Help > Get Help.

 

Cheers,

 

-Alex

If this was helpful, click the Kudos button below.
Please mark it as a solution if solved your issue so others can benefit from it 🙂

Meraki Dashboard used to have that option under Monitor -> Appliance Status -> Tools, but somehow they took that away.   I've put in feature request for many times, but I still do not see that option.  I've done set lease time, created and removed dhcp reservation scope, but it did not work like the way I want.  This's very annoyed.   

@AlexC 

 

This seems like a work-around at best. I hope this "feature" makes it to Meraki. 

 

I try to talk up Meraki when I can, but things like this makes it really difficult.

zcsdfsfsdf


@AlexC wrote:

@jvelasco wrote:

Hi, 

May I know if there is a way to clear out the DHCP Leases in a certain VLAN?

I configured static IP addresses but their previous addresses are still there in the dashboard. 


Thanks!


Hi @jvelasco,

 

A 'button' to clear DHCP Leases from dashboard is certainly a feature request at this time point in time as others have commented.

 

However, there is a way to clear the DHCP Leases on a VLAN without having to reboot the appliance by following these steps:

- Create a DHCP Reservation on the VLAN that blocks out the entire DHCP range

- Save the configuration and let MX downloads it (might take a minute or two)

- Clear the DHCP Reservation and save the configuration again

 

Hope this helps, if you are still having trouble, I would recommend reach out to support (that's whom I got this info from). You can find support information from dashboard under Help > Get Help.

 

Cheers,

 

-Alex


UPDATE FOR ANYONE THAT MIGHT RUN INTO THIS

 

I found this thread because I had to do this for a VOIP rollout.

 

I repeated these steps - 

  1. Decreased the DHCP Lease Time to 30 minutes 
  2. Create a DHCP Reservation on the VLAN that blocks out the entire DHCP range
  3. Save the configuration and let MX downloads it (might take a minute or two)
  4. Clear the DHCP Reservation that blocks out the entire DHCP range
  5. Save the configuration again

It seemed to work at first. All client DHCP leases were removed from the dash... except they some came back with the original entries. All of the phones are still advertising that their lease time will expire in 20+ hours. Effectively maintaining the lease time they originally had. 

 

Not sure if this is because they're VOIP endpoints, but it only half worked.

 

The machines on the same VLAN cleared out their DHCP leases and were on the new 30 minute lease time, the phones were not. 

This worked like a charm, the support tech wasn't aware of this technique!  Thanks Meraki Community!

Batch Imaging and deploying 75 computers caused pool to fill up. Count me as one more vote for a method to manually clear inactive DHCP leases. 

 

T-800

CptnCrnch
Kind of a big deal

Just "Make a wish" on the DHCP configuration page

JaiminPatel
Here to help

You can perform the reset on MX to clear the DHCP lease. I just did it on my Z3 and it worked.

Please take a note that there will be a down time if you reset the MX.

S_Tech
New here

I realize this is an older post. But wanted to update in case anyone else was running into this. This worked for me. 

I put Fixed IP assignment in using the IP address that I wanted to release and save that. 

It took it out of the lease then I removed the Fixed IP saved again.

the computer was able to DHCP the address.

 

Hope this works for others.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels