ASM sync not pulling in classes

Here to help

ASM sync not pulling in classes

Hi, I have a case open (02915417) but after sending screenshots 2 weeks ago I've had no response since.


Basicly when running ASM sync its pulling in the users but not the classes/groups, simply saying '0 groups synced' when there are groups setup on ASM. This happens when syncing on the both the owners page and when syncing via education profile section.


Also when its trying to assign the education profile to any of the iPads the following shows in the activity log:


Error: The payload “Student iPads” is invalid.
Error: A user with the identifier “long id number” could not be found


This is frustrating as we previously had the legacy free version, but wanted Apple Schools/Classroom integration. We had a trial and it worked fine (was a bug with class names showing as ID's but this was fixed) so its weird that a few weeks later it no longer wants to sync the classes/groups. The whole point of getting a license was to use Apple Classroom but without the classes syncing I might as well of stuck to the free version.


Any ideas on how to get this syncing? I've tried creating and uploading a new DEP token but this had no impact.


Other things I've noticed are it's also not applying any webclips we have assigned (this isn't so important, but was working previously) and any changes made to a profile that is applied via user tag won't update until the device owner is changed away from and then back to the correct owner.

9 Replies 9
Building a reputation

is it all looking good in ASM ? Do students and teachers appear in classes ? 


first thing to look at is if problem is with ASM or Meraki




Thanks for the reply, Yup all looks good (I think), see screenshots showing 13 classes setup on ASM:



Owner ASM sync shows 32 users (correct) but 0 classes:


And owners have no groups listed (this is the same user as first image):

Building a reputation

but in ASM again, have students and teachers been assigned to classes as in my screenshot

Hi, this is the student account linked to the above class:


And when viewing the class it appears to be correct:

Might be going completely off track but when looking at the user ID in ASM its completely different to Meraki (but the same format). I've blanked the center part as not sure if its sensitive info:




<Edit> ignore that it must be a different ID as ASM listed ID changes each request, don't know if its possible to view UID in ASM I'll keep looking.


I haven't used ASM but have you tried unlinking ASM from Meraki and re-linking it. 

Kind of a big deal

Are you using shared devices? I am pretty sure that Webclips don't work with those. I would try what @BlakeRichardson.

Find this helpful? Click the kudos button. Thanks!

Whilst the student one are setup as shared the staff ones are not, but the webclips don't show on those either. Apps, wallpaper etc all come over fine.


I've removed the DEP server token, generated a new one, uploaded it, still no classes syncing.


Our old legacy account is still active and had some users listed (but did have the DEP token removed ages ago) so I've gone in and removed the users from the old account just in case this was causing it but no change. Also changed it over to a different MDM certificate. Could the old account still be interfering in some way? Only thing I can think of.

Just did a sync this morning and the classes are now pulling through! so looks like an update at Meraki end I guess, as I've not made any changes.


Not fully tested it yet, so don't know if the webclips are working but at least the classes are showing now.



Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.