Creating L3 interface on MS225

mhurley131
Here to help

Creating L3 interface on MS225

I am trying to create L3 interfaces on a MS225, but am getting the following error:

 

"This switch does not support OSPF routing". 

 

The switch does not support OSPF, but it complains that it needs the OSPF commands in the POST.     Is there another syntax I should try?

 

I have tried the following:

{
"name": "L3 interface",
"subnet": "192.168.1.0/24",
"interfaceIp": "192.168.1.2",
"multicastRouting": "disabled",
"vlanId": 100,
"defaultGateway": "192.168.1.1",
"ospfSettings": {
"area": "0",
"cost": 1,
"isPassiveEnabled": true
}
}

 

 

{
"name": "L3 interface",
"subnet": "192.168.1.0/24",
"interfaceIp": "192.168.1.2",
"multicastRouting": "disabled",
"vlanId": 100,
"defaultGateway": "192.168.1.1",
"ospfSettings": {
"area": "disabled"
}
}

4 REPLIES 4
Inderdeep
Kind of a big deal

@mhurley131 : Can you check this 

https://developer.cisco.com/meraki/api-v1/#!update-device-switch-routing-interface 

Regards
Inderdeep Singh
www.thenetworkdna.com ( Awarded by Cisco IT Blogs award 2020)
rymiles
Meraki Employee

try this

 

"area": "ospfDisabled"

Bruce
Kind of a big deal

If it is "ospfDisabled" then the notes on the API reference need some clarity as they state, "The OSPF area to which this interface should belong. Can be either 'disabled' or the identifier of an existing OSPF area. Defaults to 'disabled'."

 

rymiles
Meraki Employee

agree the notes should clarify if OSPF is not enabled already on the network then the call requires ospfDisabled vs. disabled.

 

i'll report this to the API folks for confirmation and fixing.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.