View failed to load.

Here to help

View failed to load.

Is there anything going with Meraki Dashboard? I get View failed to load pop ups at random times at multiple controllers. 


Anyone experiencing this?

Cool dudes use Cisco Meraki (⌐■_■)
Kind of a big deal
Kind of a big deal

Not that I am seeing, do you get the error when trying to access a specific page in your dashboard or is it random?


Have you tried a different web browser?

This happens to me specifically when trying to any of the switches view.


Happened to me at different locations, networks, devices, browsers, Network Admins sharing access to these Networks ORGs experience same randomly. 

Cool dudes use Cisco Meraki (⌐■_■)

Has this just started happening recently or has been happening for some time?


What sort of device do you have thats doing your content filtering?

I haven't had any issues.  Can you post a screenshot or explanation of what is going on?  Also I assume you tried a different browser, clearing temp/cookies etc?


If this was helpful click the Kudo button below
If my reply solved your issue, please mark it as a solution.

I am getting the same thing tonight. I have tried deleting cookies and multiple browsers




New here

I just started getting this error on multiple switches on different browsers. I have also deleted temp files and cookies and problems seems to still exist.

Just browsing

I´ve been having the exact same issue since Friday. Sometimes randomly, but always going from a client in client view directly to the port its connected to. Dont know if its related to our recent switch upgrade to 10.35, but never had this issue before that.

Getting noticed

Yes. We've been seeing this and have an active case.

Awesome, wanted to try the community before opening a case. Wondering if related to firmware then. Have you got anything from Meraki Support?

Cool dudes use Cisco Meraki (⌐■_■)

Nothing substantive yet.

Here to help

Getting the same on details in switch port view

Here to help

I'll open a case with Meraki Support today, pretty sure will go directly into engineering and will be ask to standby, will update you all later on.



Thanks, Community!

Cool dudes use Cisco Meraki (⌐■_■)
Here to help

I am experiencing the same issue.  I was able to work around it by going to the general settings and choosing to upgrade to the latest stable version, and it shows up under the Most Recent Changes in the Organization tab, but the "All Networks" tab seems to be "broken".  Did you get any response back from Meraki support?  I just submitted a ticket.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.