Meraki Mobile Dashboard not logging in

Getting noticed

Meraki Mobile Dashboard not logging in

Hi guys,


I am trying to log into the mobile app on iOS to be able to view my devices and dashboard.


However, I can't login. I enter my username and password but the button just goes "Logging in..." forever.


It's been like this for over 3 months, when is this gonna be fixed? Is there a way to bypass that? I have 2FA enabled, can this be the problem?

1 Accepted Solution

Probably a little mistake in the app that needed quick fixing! Now it works like a charm!


@MerakiDave If someone at Meraki fixed the app just for me, I thank you.

View solution in original post

14 Replies 14
Kind of a big deal
Kind of a big deal

I have 2FA enabled but I use it on Android.


Perhaps try deleting the app and re-installing it?

Obviously I tried that.

I tried everything with this app, it just doesn't work anymore and hasn't been updated in over a year.
Meraki Employee
Meraki Employee

I won't disagree the mobile app seemed a bit neglected this past year and it's overdue for some improvements.  Just a couple quick thoughts, you've already reinstalled the app, but have you also tried it from some other mobile device?  If only temporarily, borrow another iOS device some a friend of family member, and see if you can log into the mobile app from theirs.  And if so, compare iOS versions, etc.  Also try an Android device, and see if you can log in from an Android phone or tablet.  Temporarily disabling 2FA might be worth trying, see if that changes anything.  Beyond trying these things, I'd suggest calling into Support to see if there's any known issues.

I will try disabling 2FA but note that this is a mandatory security feature in my business. We need the app to work with it.

I do not have any Android devices but I will try a few things. Also, I did try on other devices and it doesn't work either.

@MerakiDave I am having the same issue.  I can login via the website, but for some reason, the iOS app does not work on three different devices.  Any other suggestions (2FA is turned off).

Hi @alas sorry no other suggestions I have really other than the usual troubleshooting like clearing cache, rebooting the device, reinstalling the app and making sure it is granted whatever permissions it may need, etc.  Are the 3 different devices all the same device type of OS version?  I'l log a case with Meraki Support to confirm if there's any known issue regarding your device/OS, and if so they can add you to the bug ID if there is one.

We have the same troubles. We are three active administrators with full Organization access and TFA deactivated and all three have the same settings in Administrators overview.


Only one Admin is able to log in through the App, two of us are experiencing the same issues as already mentioned in this thread.


Tried on different devices with fresh installed Apps.


Two devices are an iPhone 7 32 GB iOS 12.2, another device iPhone 7 128 GB iOS 12.2


The admin with working log in runs on iPhone 7 32 GB iOS 11.3.1

A model citizen

@MerakiDave @alas 


OK, I think I figured it out.


Under my profile settings I had multiple sessions with no ending date. I killed all of them and since then I‘m able to log in on both of my devices.

This worked for me!

Thank you @beks88 🙂

Mine is working perfectly.
Kind of a big deal

Using Android and IOS, both are working fine...


ios version: 2.3.9-12-g6d6f76f6-v10 - build 01.12.2017


colleagues use the same and is working as well...

Well what's funny is that someone at Meraki fixed the app.

It wasn't working after multiple (tens) tries and now it worked this morning. It asked for my 2FA code and logged in.

NOTE: the login page had a weird "refresh" behavior when you would open the app. Like the page needed to load a second time. Now it doesn't do that. Same device, same iOS, not even reinstalled between yesterday and today.

Good to hear. Your desperate cry for help must've been heard!

Probably a little mistake in the app that needed quick fixing! Now it works like a charm!


@MerakiDave If someone at Meraki fixed the app just for me, I thank you.

Get notified when there are additional replies to this discussion.