Cisco Services down?

Head in the Cloud

Cisco Services down?

Anyone else not able to reach Meraki Dashboard or even Webex? won't load either.


CN Dashboard responds and is available, though.

Meraki Employee

Hey @rbnielsen ,


I'm UK based and everything is loading fine for me.


Have you tried some traceroutes & nslookups to pinpoint what the traffic is stopping?


Many thanks!



Please keep in mind that what I post here is my personal knowledge and opinion. Don't take anything I say for the Holy Grail, but try and see!
Appreciate who helps and be respectful of every opinion and every solution offered.
Share the love, especially the Meraki one!

Rumour has it, it might be an ISP issue. 


Github is unavailble, as well as 



And it seems to be back again. 


Funny though, because all customers on TDC ISP in Denmark seemed to be affected, but when doing traceroutes, it looked like the issue was further out, than TDC network. 

Kind of a big deal

Fine here. Been using Webex all morning and CCWs loading fine

Darren O'Connor |

I'm not an employee of Cisco/Meraki. My posts are based on Meraki best practice and what has worked for me in the field.
Kind of a big deal

Azure had a major outage around that time period.  Perhaps Azure is used for part of the operation. 

Kind of a big deal

@rbnielsen : Azure down , These days a lot of platform down like Facebook & companies and now Azure 🙂

Inderdeep Singh ( Awarded by Cisco IT Blogs award 2020)


Rumour has it that our ISP had an issue with the transatlantic line to New York…
Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.