Bizzar error on Meraki Access point with some HP Computer

Here to help

Bizzar error on Meraki Access point with some HP Computer

Hello , 

Since some month, i had this issue in all my HP Probook G9 in italy with the Realtek 8852BE.

We can see this message on the Timeline windows : 

Unexpectedly disassociated, but the client had a successful connection to SSID Agap2 for a few seconds on access point 1-IT20WI-001.

802.11 REASON (CODE 51)
Invalid FTE
Sometimes every two minutes, I got the issue even with one access point onsite
Can anyone help me ? 
10 Replies 10
Kind of a big deal
Kind of a big deal

Sounds like an 802.11r issue. Is it enabled?

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.

I think your right on the money there. Otherwise @Nightstick  what firmware version are you using and are the wireless drivers up to date? 


What authentication method are you using?

Sorry for the late , 

WPA2 PSK , for now i'm on the new 30.5 but it was the same on OLD firmware ,



no , but i've tried to enable it.... same issue

Kind of a big deal
Kind of a big deal

Have you checked to see if RealTek (not HP) have a new WiFi driver for that chipset?

Building a reputation

Seconding this as probably the easiest thing to try/check.


I spent a fair bit of time last month tracking down what sounds like maybe a similar problem - folks complaining about completely random disconnects. When I went digging in the AP event logs, it really looked like the clients were severing their connections for an unknown reason. Thought maybe a sleep/power save feature was the issue but ruled that out pretty quick.


It turned out to be a faulty driver with a newer model of HP Laptop that recently started being deployed back in June, the driver issue had been present from the get-go but didn't hit critical mass until early October. This was specifically HP PB650G8 laptops with the Intel(R) Wi-Fi 6 AX201* wireless NIC, we snagged the latest driver from Intel's site, deployed it, and the problem went away entirely.

i've check on the HP website for G9 HP Proobook  , there is not update since July , and on the Realtek Website , The page for the Card RTL8852BE does not exist....

Kind of a big deal
Kind of a big deal

Also avoid WPA3 for the moment.  There is a Windows 11 bug that causes random disconnects.  Microsoft is scheduling a fix for that in April 2024.

I use WPA2 with Windows 10 22h2 but i've the same issue

A model citizen

Just as a matter of fact, Realtek chipsets are notoriously buggy  and often have much lower performance,  in my experience. swap that radio out...

Get notified when there are additional replies to this discussion.