Wireless Splash Page


Wireless Splash Page


We are using a "Click-Through" for one of our Wiresless networks that redirects the users to a splash page with company information and a button for accept.


This works perfect on Android but for all iOS users it doesnt bring them to the splash page so they cannot use the WiFi.


We are using Ciscos own splash page URL: https://n193.network-auth.com/xxxxxxx


Thank you!

Kind of a big deal

Does the splash page pop up when they try to access an HTTP website (e.g. http://fixwifi.it)?

Yes, if i try in the Safari browser i go to the splash page and it works.

Okay. Do you have any pages in your walled garden? Because the way it's supposed to work is, when IOS connects to a WiFi network, it detects the availability of internet access by trying to open certain pages. If it can, it doesn't open a splash page, if not it presents you with the splash page. If the walled garden allows access to those pages, then that technique fails.

As BrechtSchamp said , IOS devices needs to contact captive.apple.com to validate if the device as access to the network 




Personnaly , I have whitelisted *.apple.com. But I know for a fact that a lot of people have issues with IOS and splash pages.


Ive tried with walled garden disabled and enable and with it enabled with *.apple.com and without it. With zero results.

Hmm weird.


If you "forget" the network in IOS and then connect again, do you get the captive portal then?

Ive tried that also, ive tried on 4 different iPhones doesnt work. Ive tried on 2 different Androids and it works immeditaly

Experienced the same problem with the Splash Page showing only for Android devices but not for Apple Devices.


You can try the following:

  • Checking the Firmware version running on the AP's to see if there is any known bugs - possibly try upgrading the access points.
  • Check if there MDM software on the IPhones and not on the Androids.
  • Are you able to run a packet capture when the device try to connect?
  • Maybe check the wireless  health under the wireless - monitor tab to see the number of failed connections and the reason for them. - Might be difficult as the devices are not getting to the splash page to even authenticate.
  • Review any firewall rules which could be preventing connectivity to cisco specific splash page. - If there was a rule blocking it I would expect it to impact both IPhone and Android.

We never managed to get a resolution for our issue as we migrated to a PSK instead.


Hopefully the above helps.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.