Meraki MR42e management IP via DHCP not working

SOLVED
Mamba123
Getting noticed

Meraki MR42e management IP via DHCP not working

hi Guys
I have a problem.

I got a new MR33 and 4 new MR42e APs and should set them up.

The APs are connected to a Cisco 2960 switch, switch port is configured as a trunk with Native VLAN 555.

VLAN555 also assigns the IP address and comes on the Internet.

An MR33 works without problems, it gets the correct IP from the VLAN555 and is immediately visible in the dashboard. Everything OK.

But not a single MR42e gets an IP address. Why not? What is different with an MR43e than with MR33?

I also cannot access the local page on the MR42e. The way it is described on the Meraiki page does not work.

Can anyone help here?

 

Best regards

Mamba

1 ACCEPTED SOLUTION

Accepted Solutions
Network-dad
A model citizen

Re: Meraki MR42e management IP via DHCP not working

do you have the vlan set on each ap?

Network-dad_0-1592933008607.png

If not reboot the ap after setting it...

 

 

Dakota Snow | Network-dad Linkdedin
CMNO | A+ | ECMS2
Check out IT Career Skills onIt Career SkillsIt Career Skills

View solution in original post

10 REPLIES 10
Network-dad
A model citizen

Re: Meraki MR42e management IP via DHCP not working

Are the MR42e's getting POE? Have you confirmed they are powering on? what is the status light?

Dakota Snow | Network-dad Linkdedin
CMNO | A+ | ECMS2
Check out IT Career Skills onIt Career SkillsIt Career Skills
Mamba123
Getting noticed

Re: Meraki MR42e management IP via DHCP not working

Hi, yes PoE is enabled. LED status is blue.

Network-dad
A model citizen

Re: Meraki MR42e management IP via DHCP not working

My guess the Cisco 2960 may not have the proper POE of the MR42e's... Cisco 2960 specs here

the MR42e requires "Power over Ethernet: 37-57 V (802.3at required; functionality-restricted 802.3af mode supported)" MR42e's specs here...The Cisco is  IEEE 802.3af-compliant but that mean the MR42e is operating in functionality-restricted mode... Also depending on the model of 2960 not all ports provide POE. The Cisco Catalyst 2960PD-8TT-L Switch only has 8 ports of POE have you tried plugging it into a different type of switch? 

Dakota Snow | Network-dad Linkdedin
CMNO | A+ | ECMS2
Check out IT Career Skills onIt Career SkillsIt Career Skills
rbnielsen
Head in the Cloud

Re: Meraki MR42e management IP via DHCP not working

Adding to @Network-dad, the MR33 is a 802.3af (normal PoE) AP, whereas MR42E requires 802.3at (PoE+).

 

If the MR42E is only getting .3af, it will power up in low power mode, meaning Air Marshall is disabled, as well as two out of three streams. For your reference, it's noted in the installation guide.

 

Edit: Ninja'ed by @Network-dad himself. 😉

Network-dad
A model citizen

Re: Meraki MR42e management IP via DHCP not working

Your MR42E is equipped with a multi-color LED light on the front of the unit to convey information about system functionality and performance:

  • Orange - AP is booting (permanent Orange suggests hardware issue)
  • Rainbow - AP is initializing/scanning
  • Blinking Blue - AP is upgrading
  • Green - AP in Gateway mode with no clients
  • Blue - AP in Gateway mode with clients 
  • Blinking Orange - AP can't find uplink 
Dakota Snow | Network-dad Linkdedin
CMNO | A+ | ECMS2
Check out IT Career Skills onIt Career SkillsIt Career Skills
Mamba123
Getting noticed

Re: Meraki MR42e management IP via DHCP not working

hi Guys
first of all thank you for quick answers.

A few more details:

1. I also tried it with a power injector. Exactly the same behavior.

2. The LED lights up blue.

3. AP is shown in the dashboard as a repeater because it does not get an IP.

If AP got too little power, I would understand that the antennas stay off, but why doesn't it get IP.

rbnielsen
Head in the Cloud

Re: Meraki MR42e management IP via DHCP not working

Have you checked that the DHCP pool is not exhausted?

Verified switchport configuration on the catalyst switch?

Network-dad
A model citizen

Re: Meraki MR42e management IP via DHCP not working

do you have the vlan set on each ap?

Network-dad_0-1592933008607.png

If not reboot the ap after setting it...

 

 

Dakota Snow | Network-dad Linkdedin
CMNO | A+ | ECMS2
Check out IT Career Skills onIt Career SkillsIt Career Skills

View solution in original post

Mamba123
Getting noticed

Re: Meraki MR42e management IP via DHCP not working

Hi,

 

VLAN was not entered. As I said, MR33 works perfectly on the switch and gets the IP address from the DHCP server.

Yes, DHCP Scope is big enough. I tried two things. One external DHCP server and one DHCP on the switch.

in both cases MR33 works fine and MR42 does not.

I have 4x MR42 and the same problem with all of them. All APs are new and have been supplied by Cisco.

The only difference is the power consumption.

I'll test it in the company tomorrow morning and give you feedback.

AP may not get enough power and cannot boot properly.

LuisCruz
Here to help

Re: Meraki MR42e management IP via DHCP not working

Leaving the VLAN field blank means that the AP will try to get an IP from the native VLAN DHCP scope (VLAN555 in your case). Try changing the native VLAN on the 2960 to something else, then set the VLAN field on the AP to 555, this way the AP will try to get an IP from tagged VLAN 555 scope.

 

This would be some strange behavior, but at least we will get some info to have a case open.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.