cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Meraki MR42 won't take new IP address

Comes here often

Meraki MR42 won't take new IP address

I have two MR42s that will not accept the IP address I want to give them. One stubbornly holds on to the first address I gave it, a.b.c.97; I have tried many times to change it to a.b.c.96, but the AP never remembers the change--it doesn't respond with an error message or anything, in fact when I click on the "edit" icon a table with all the right values comes up, so it's storing the information somewhere--but the address never changes.

Another AP got an address from DHCP a month or two ago, a.b.c.129; I want to give it a static IP address (like all the other APs at the site), a.b.c.100, but I might as well be talking to a cat. I have rebooted and power-cycled both APs.

What else can I do without going to the sites in question, getting on a ladder, and doing a manual factory reset?

Why are these boxes sometimes so stubborn about IP addresses?

6 REPLIES 6
Kind of a big deal

Re: Meraki MR42 won't take new IP address

My guess is the AP isn't receiving changes you make to the config. If you click on the AP and look at the bottom does it say Config : "Up to date"

 

A way around this is set the AP to DHCP and statically assign the IP from your DHCP server using its MAC access.

 

One last thing the IP you are trying to set have you confirm that IP is available and nothing else is using it?

 

Meraki AP info.png

Meraki CMNO, Ruckus WISE, Sonicwall CSSA, Allied Telesis CASE & CAI
Kind of a big deal

Re: Meraki MR42 won't take new IP address

Are you running a recent software version like 25.8?

 

Personally, I'd be doing the factory reset option.

Kind of a big deal

Re: Meraki MR42 won't take new IP address

ps.  I assume you can't ping the new IP address you are trying to change it to (as in, the IP address is definitely unused).

Comes here often

Re: Meraki MR42 won't take new IP address

Yes, it's vacant. No response to pings, no entries in arp table after ping attempts.
Comes here often

Re: Meraki MR42 won't take new IP address

There are four other APs at the same site, plugged into the same switch, that have no problem at all. Only this one says it has problems communicating with Meraki.
I think I'll try your DHCP trick just to teach it a lesson.
The IP address is definitely unused.
Meraki Employee

Re: Meraki MR42 won't take new IP address

Philip and Blake pretty much covered the options.  I'm wondering if the AP is somehow not able to properly communicate with the cloud controller to get the static settings you gave it, possibly due to some local VLAN or native VLAN mismatch or ACL issue.  Meraki devices have a dual-partition NVRAM and always have their last known good firmware and config file, so if the new settings aren't taking effect and it considers itself unreachable, perhaps it's reverting to its previous config and you're seeing the same settings come back when it resurfaces in Dashboard.

 

I'd also run a packet capture on the AP's switch port and see exactly what DHCP frames might be there.

 

One other idea that doesn't involve a ladder is to just let the AP come up however it comes up, and as long as you're associated to an SSID on that AP, you can open a browser window to ap.meraki.com and use the local status/config page and go to the "Configure" tab to manually set the static IP.  More info here https://documentation.meraki.com/zGeneral_Administration/Tools_and_Troubleshooting/Using_the_Cisco_M...

 

Doing this in Dashboard, I'd clear the AP's config (clear any static IP/GW/DNS settings and leave it at DHCP with no VLAN assigned).  If you wanted to for good measure, you can remove the AP from the Dashboard network, it'll show up as an unused AP under Organization > Inventory and you can make sure there's no trace of it under Wireless > APs.  You could even unclaim it from your Dashboard Organization and reclaim it by its serial number.  Then paperclip the AP for 30 seconds to force the factory reset.  While it's rebooting, add it back into the wireless network (if you previously removed it) and have it on a switch port & VLAN where it can grab a DHCP address.  If so, it should go green in Dashboard and accept static IP settings successfully from there.   

 

If everything we've all discussed in this thread is still falling short, open a support case for a closer look with someone live on the phone and sharing your screen on a webex.

 

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.