cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Epson Wireless printer won’t connect to MR33

SOLVED
Here to help

Epson Wireless printer won’t connect to MR33

I have a Z3 gateway, and an MR33 access point.

 

no matter what settings i put on the SSID of the MR33, my Epson SX535WD printer will not connect properly to the MR33. Yet if I set up an ssid with the same settings on the Z3 it works fine.

 

all other clients and even silly little 2.4GHz boxes (lighting controller, AV Recievers) work perfectly with the MR33, it’s just this Epson that refuses to connect up properly. It connects, but doesn’t get dhcp, and with manual ip settings I can see it try and connect in Meraki dashboard, but doesn’t actually get a successful connection.

 

i want to turn off the Z3 Wireless completely and use the MR33 solely for Wireless.

1 ACCEPTED SOLUTION

Accepted Solutions
Here to help

Re: Epson Wireless printer won’t connect to MR33

It is all very strange, but I did manage to solve it.

 

i had to do a full reset on the printer, then before connecting to any wireless network, set the up address up manually, and then connect to the SSID of the MR33.

 

mv-was-here.png

26 REPLIES 26
Head in the Cloud

Re: Epson Wireless printer won’t connect to MR33

Do you want to share what your settings are?  I can just guess some things like trying to disable band steering and maybe 802.11r if you turned it on.  You can also call Meraki support and see what they think.

Getting noticed

Re: Epson Wireless printer won’t connect to MR33

Hi @DJSky

 

Is the MR33 on the same VLAN with the client's network?

If yes, can you client ping each other on the same VLAN? (Wireless client ping PC - LAN cable client)
If no, can you check the Access Point > Access Control if the DHCP is in Bridge Mode and Access Point > Firewall & traffic Shaping > Set to Allow.
While ensure the Z3's Firewall nothing is block too.

Kind of a big deal

Re: Epson Wireless printer won’t connect to MR33

Any firmware upgrades for the Epson?

 

Have you got 802.11r enabled?  it so, try turning it off.

New here

Re: Epson Wireless printer won’t connect to MR33

I have the same issue Epson WP-4350 which can does not get a IP address from the MR33. I tried to put a static IP address on the Wifi setting but is still does not connect.

Any ideas 


New here

Re: Epson Wireless printer won’t connect to MR33

PS I also upgraded the Firmware on the Epson WP-4530.

The strange thing is the Printer connects to the MX65W directly but will not connect via the MR33. The MR33 is connected to the MX65W via a MS220-8P.

Getting noticed

Re: Epson Wireless printer won’t connect to MR33

Hi @MartinJvR

 

I never try that before but if the concept is correct, Disable the VLAN, and use only 1 VLAN, then make sure the MR33 is Bridge in the Access Control.

It should work but there won't be Roaming feature.

 

Regarads

Tony

Here to help

Re: Epson Wireless printer won’t connect to MR33

It is all very strange, but I did manage to solve it.

 

i had to do a full reset on the printer, then before connecting to any wireless network, set the up address up manually, and then connect to the SSID of the MR33.

 

mv-was-here.png

Getting noticed

Re: Epson Wireless printer won’t connect to MR33

Hi @DJSky

 

Nice!

1 more tips for you!

Instead of static ip on your printer, leave it as DHCP and configure in Meraki to that Mac Address to 1 fixed IP only so it will be so easy to manage everything in the Meraki when it's trouble when your client is not IT savy.

 

Capture.PNGSecurity Appliance > DHCP

Highlighted
Here to help

Re: Epson Wireless printer won’t connect to MR33

I had already tried this, but it is the first initial connection to wireless that messes the brain of the Epson up, hence having to set the static IP up first on the printer before connecting.

New here

Re: Epson Wireless printer won’t connect to MR33

Hi Tony_Ang,

Is the MR33 on the same VLAN with the client's network?

  • Yes they are on the same network.

If yes, can you client ping each other on the same VLAN? (Wireless client ping PC - LAN cable client)

  • No the Printer would jut not get a Ip address .. got the 169xxxxxxxxxx address which means it can not get a IP.
  • I even set the ip to static on the Router no luck...
  • Then I setup a static DHCP for the Mac of the Printer ...
  • The I finally just connected the Printer to a Lan cable and pointed the PC to the Ipa Add of the printer 
  • Yes got it set to bridge mode 

New here

Re: Epson Wireless printer won’t connect to MR33

It is working now on the LAN cable ... no Wifi 😞 

Conversationalist

Re: Epson Wireless printer won’t connect to MR33


@MartinJvR wrote:

It is working now on the LAN cable ... no Wifi 😞 


We have two WP-4535 DWFs and there are two things I can note regarding Wi-Fi connectivity. These may not apply to your printer.

 

First, the printer seems to get confused once network settings are saved for the first time then need to be changed. When I have problems with the Wi-Fi connection, I reset the printer and enter the network settings again. This usually works.

 

Second, the printer connects to the 2.4 GHz band and it would seem doesn't connect to an AP, in our case MR32s, if the minimum bitrate isn't set to 1 Mbps.

Conversationalist

Re: Epson Wireless printer won’t connect to MR33

Seeing similar issues with an Epson WorkForce 545 + MR33. Epson software is up-to-date

 

Here's what I've tried.

 

  • Resetting Epson to factory settings + reconfig wifi on device. No Joy.
  • Whitelisting Epson via MAC address in Meraki Dashboard. No Joy.
  • Setting a BonJour Forwarding Rule in Access Control. No Joy
  • Assigning manual IP config in Epson control. 1/2 Joy.

With a manual IP, Subnet, and Gateway assigned in the Epson, the device now appears on my network and in the Meraki dashboard, but attempts to print are still unsuccessful.

 

Every other device on my network is operating nominally. Clearly, this is an issue with the Epson WiFi.

 

My next step will be to create a new vLAN for the Epson with a 1MB min bitrate as @thnat tried.

New here

Re: Epson Wireless printer won’t connect to MR33

100% fix for me and my WP-4530 was to go into Access Control under the SSID you are connecting to (mine is a MR33, only one SSID) and set the "Minimum bitrate" to either 1 or 2 for max compatibility. I played with this, and anything higher with this particular printer will not connect. Even after updating the firmware to the latest of around May 2018, still cannot move the min bitrate higher than 2. Must be cheaper hardware with limitations, wireless band is n.

 

Prior to this I did the factory defaults and various manual/auto IP configurations, but nothing worked until I changed the min bitrate.

Conversationalist

Re: Epson Wireless printer won’t connect to MR33

Agreed.

 

I forgot to follow up here, but I have the same results after changing minimum bitrate to 1MB. With the SSID on set to 1MB minimum, the Epson printer now connects wirelessly just fine.

 

 

Getting noticed

Re: Epson Wireless printer won’t connect to MR33

Hi @MartinJvR

 

Can you let me know again what MX model are you using? If you're using MX65W please turn off the WiFi module on the MX65W and use MR33 instead.

Also if you don't mind, maybe if you can screen shot some configuration of your Meraki:-

1) MX's Addressing & VLAN

2) WiFi Access Control

3) MX & MR Firewall configuration

4) Is your MR33 connect directly into your MX65W's PoE port 11 or 12?

5) MX's DHCP of the VLAN

 

Thanks & regards,
Tony

 

 

Conversationalist

Re: Epson Wireless printer won’t connect to MR33

I had a similar problem with another printer brand (Brother Brasil).

 

To solve my problem I had to include the printer MAC Address in the Air Marshal SSID whitelist

.

Did you try that?

 

Regards,

Getting noticed

Re: Epson Wireless printer won’t connect to MR33

Hi @LucasCarvalho

 

Did you mean like as per below?
I think it's more on the MX 

 

Capture.JPGSSID WhitelistCapture.JPGSecurity % SD-WAN > DHCP > Fixed IP assignments

Also you need to ensure the WiFi VLAN is accessible to the Printer's VLAN. You can do a simple test by ping.

Also take note below Access Point Firewall should allow as well.

 

Capture.JPGWireless > Firewall & traffic shaping

If it's a difference VLAN then you need to go to "Security & SD-WAN > Firewall" and "Allow" the subnet to the destination of the printer IP Address.

 

Capture.JPGSecurity & SD-WAN > Firewall > Layer 3Hope this helps 🙂

New here

Re: Epson Wireless printer won’t connect to MR33

Shouldn't matter. From what I understand of your problem description, if your computer is connected to the Meraki and your printer is on your original AP, or vice-a-versa you can't see the printer. If the computer is expecting to find the printer with Bonjour, then the Meraki will need this option enabled so it relays the Bonjour frames back and forth.

Kind of a big deal

Re: Epson Wireless printer won’t connect to MR33

I FOUND THE GNOME!

Community Manager

Re: Epson Wireless printer won’t connect to MR33

@BrechtSchamp too easy this time!? Nice work! Thank you for finding the gnome!

Caroline S | Community Manager, Cisco Meraki | @merakicaroline
New to the community? Get started here
Kind of a big deal

Re: Epson Wireless printer won’t connect to MR33


@CarolineS wrote:

@BrechtSchamp too easy this time!? Nice work! Thank you for finding the gnome!


Well, maybe I just got lucky, but the clues do help. The hard part was the wait for you posting it though... I had my mind set on not losing the challenge again.

Community Manager

Re: Epson Wireless printer won’t connect to MR33

@BrechtSchamp - your dedication paid off 🙂

Caroline S | Community Manager, Cisco Meraki | @merakicaroline
New to the community? Get started here
Here to help

Re: Epson Wireless printer won’t connect to MR33

EGG FOUND!!
New here

Re: Epson Wireless printer won’t connect to MR33

Turning off band steering fix this issue for us as well.  The epson printer would not even see our wifi until that was done.

Getting noticed

Re: Epson Wireless printer won’t connect to MR33

I have a feeling it's Meraki MR33 have this issue. I tried with Ubiquiti Unifi nano-HD APs with band steering no issue at all and the signal is better than MR33. But I'm rolling out MR42 to all my organization in my company for now. Currently studying Meraki products about WiFi 6 but the mGig switch are expensive. Hope they will come out model like MS120 with mGig and more ports on it. I need to try the WiFi 6 as we are moving towards Modern Workplace and no more LAN cables. So wireless printers gotta work as well.

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.