Switch Stack

Building a reputation

Switch Stack

Hi all,


I am having an issue with a switch stack of four MS350-48FP switches. My Dashboard is displaying the following:


"This switch's current stack members differ from the dashboard configuration."


The third switch in the switch stack is stuck on an orange LED status light.


I've tried to reboot the entire switch stack, but nothing has changed.


How can I troubleshoot this to resolve it?

Kind of a big deal

The error you're seeing is because the third switch isn't connecting to the Dashboard - hence the orange LED - and so isn't seen as being part of the stack. First, if you haven't already, make sure all the stacking cables are pushed home properly in all the switches.


IF that doesn't change things, take the switch with the orange LED out of the stack both physically and within the Dashboard. See here for the Dashboard part, under Managing Stack Members, https://documentation.meraki.com/MS/Stacking/Switch_Stacks.


Then try and get the switch working as a standalone device, e.g. do a factory reset etc. If you can't get it working then log a ticket with support as its possible the switch has 'gone bad', and need replacement. If you do get it working as a standalone you should then be able to add it back into the stack.

Building a reputation

When removing the switch as a member of the switch stack, will it remove the configuration on the switch as well?

Kind of a big deal

From what I remember (although its been a while) the port configurations should remain since they are tied to the switch not the stack, but any Layer 3 interfaces, STP priority settings, etc., will remain on the stack, and LACP aggregates will break. That said I'd make sure I have a copy of the port configurations just in case.


Hopefully you also have a port on the switch configured which is on the Management VLAN so that the switch can connect back to the cloud. If not then you'll need to make a change on the Dashboard to add a port to the Management VLAN, then reset the switch so that it tries to connect to the cloud through an access port (or native VLAN), remembering to have the connection you just configured connected so that when it downloads its configuration it will remain connected to the Meraki cloud (otherwise it will likely revert its configuration through the failsafe mechanism if it loses Cloud connectivity).

Kind of a big deal

@Shadius : Try doing standalone switch and check if the issue is same.

Switch has a solid amber power LED

A solid amber power LED indicates that the switch is unable to communicate with the network or reach the cloud. This is rarely indicative of hardware failure, the following troubleshooting steps may help resolve the issue:

  • Connect to the switch's Local Status Page and check the management IP configuration.
    • If the switch should be getting a dynamic IP configuration via DHCP, see if it received an IP address. If not, troubleshoot the connection between the switch and DHCP server, as well as the server itself.
    • If the switch needs a static IP configuration, make sure that IP is set correctly.
    • Make sure the switch's management VLAN is configured correctly, or left blank if it should be untagged.
  • Make sure there are no firewalls that could be blocking the switch's management traffic.
  • Plug the switch's uplink cable into another device like a laptop, to test for Internet connectivity.

If all else fails, try performing a factory reset on the switch and reconfigure its management IP as needed.

At last, if nothing working, Open a Meraki support ticket.

Inderdeep Singh
www.thenetworkdna.com ( Awarded by Cisco IT Blogs award 2020)
Building a reputation

So I'm not getting any link light when I plug into the Management interface at the back of this switch. 


The switch is assigned a static IP and I'v confirmed it's set correctly. 


Even though I'm not getting any link lights from the management interface, I still tried to access switch.meraki.com and was taken to the local status page of another switch that's on a different switch stack and floor. 

Kind of a big deal

That doesn’t sound correct, especially if you’re accessing it via the management port on the back of the switch. Have you removed the switch from the stack and tried to reset it yet? (Resetting it will clear it’s configuration so it can pull it down fresh from the Meraki Cloud)

Kind of a big deal

If you are not getting a link light from the management port open a case with support and RMA it.  That's a hardware fault.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.