Static IP not working for MS350

Just browsing

Static IP not working for MS350

Hello, I have what I hope is a simple issue to resolve.


I have a MS350 switch that I want to setup with a static IP address. My problem however is that it keeps setting itself back to DHCP no matter what I do/try.


My management VLAN is 1 but the IP I want to use is on VLAN 2. From my point of view it looks no different than all my other switches configured with the same VLANs, but I cannot figure out why this one has an issue.

Kind of a big deal

Yeh... This has been a real pain in my butt as well. 


Call into support. They have some settings they can apply to help convince the MX to stick to its static and not fall back to DHCP so easily. 

Kind of a big deal
Kind of a big deal

gateway of your ip adres in vlan 2 is also at the upstream / internet device?


Have you tried keeping it at DHCP and then giving it a fixed IP assignment from the DHCP page? Since doing that, we've had zero issues getting our devices to the IPs we want.


Also, are you trying to set the static IP from the local admin page of the device or from the dashboard?

Found this helpful? Give me some Kudos! (click on the little up-arrow below)
Kind of a big deal

I also dealt with this once.  Two pieces of advice worth checking:

1.  Double check you didn't mix up the gateway and subnet mask in the wrong boxes.  I've done it.

2.  Sometimes it takes a bit for the static IP to stick.  Especially if the devices has been rebooted a lot.  I had one that didn't take it until overnight. 


Lastly as said by some of the other guys here.  Double check the port has the right vlan and the upstream configuration is the same. 

If this was helpful click the Kudo button below
If my reply solved your issue, please mark it as a solution.
Getting noticed

Management VLAN is the VLAN your switch will need to get IP address from. Management traffic (traffic generated by switch) leaves untagged. So you will need to make sure that it is also on the trunk ports at least back to appliance as a native VLAN (untagged)

It could be also, that you changing the management VLAN to 1 and IP address to 2 you cut off the management traffic to Meraki from your switch. So dashboard will show last updated information. So you could try to reconfigure it via local URL, but again your going to have a bad time because it shouldn't work like that.
Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.