Port STP Change

Here to help

Port STP Change

I've followed everyone's suggestions from this board and many others, but our ports keep changing.  It affects all ports, but it really affects our POE phones since they reboot everytime.


Our data is on VLAN 1 and our voice is on VLAN 3, so separating them isn't an issue.  We are using MS-220s at one location and MS-225s at another.  Firmware version is MS 10.45


Anyone able to assist?


This goes only 24/7






Kind of a big deal
Kind of a big deal

I have seen this issue before, how many ports are affected. If you change the port you are using in the switch does the problem follow?



I'd say all of them affected. Whenever I change ports, that port begins to have problems

Did you find a fix for this Vince? 

Kind of a big deal
Kind of a big deal

Port 22 loops like it might have a loop on it.  What does it connect to?

That's what I thought at first but there are no loops.  Port 22 is just an example of what's happening.  If I switch ports, it starts happening on the new port also.

A model citizen

All I have that is similar are my Apple TV 4K which do the very same. But of course I don't think this is related. What is plugged into the ports?

The ports that are giving me the most problems have ShoreTel POE phones plugged into them.  It is occurring on ports with computers attached, but the NICs react quicker to port status changes.

Power consumption ok as PoE usage per switch?

Yes, They only run 30-50W/740W on all of them.  I'm adding in some power injectors and will rollback updates tonight to see if that makes a difference.

We have the same issue when we have an Apple Tv plugged in at the other end.  Is there an issue with Meraki switches and Apple TVs?

Yes Apple TV´s are really an anger.

Kind of a big deal
Kind of a big deal

@redsector we have 7 Apple TVs plugged into an MS120-8P and they seem fine?  I see one of these down/up transitions about once a week per device.


The Sky boxes also sometimes do it, so do our in-house content delivery PCs.


Doesn't cause any real issue, is it just that you don't like transitions in the log?

Head in the Cloud

all Apple TV´s in several networks have the same behaviour:


Seems to be a power-saving issue with Apple-TV connected to Meraki MS switches. I can´t see any issue with Cisco "classic" switches. When they wake up the connection is green again.

Kind of a big deal
Kind of a big deal

@redsector ours definitely don't do that, here is one for the last 2 hours, last week is all green apart from being off for 4 minutes about six days ago...




I note that ours are only connecting at 100Mb/s whereas your one seems to be connecting at 1Gb/s.  Do you know what version of Apple TV hardware you have as perhaps we are lucky that the older ones work better!?!


New here

Did ya get a fix to this Vince? 

Building a reputation

Any update on this?  I'm having this constantly at a few of my Meraki locations and am currently in dialog with support on the issue.   As of yet no resolution but the exact same issue.  Computers really don't notice but every phone reboots and of course I get tons of calls.


The only way I honestly even know is I get an alert from the UPS management system telling me the UPS lost contact briefly.


I've verify power is not the issue.

Our phones (Mitel) have an issue with interacting with Meraki switches.  I changed out the Merakis with old Dell POE switches that have been factory reset.   Have experienced no issues since. 


So overall, it could be that the phones expect a certain wattage/signal from the switches and they either get bottlenecked or they get some kind of kill signal.


Either way, never could find the actual answer from either Mitel or Meraki. 


ShoreTel Phones of the IP480, IP485 models by default have power settings that go into a low power sleep mode at roughly 20:00 hours and they awake at 07:00 hours.  When they awake they usually drop the port they are connected to.  I have seen this in SYSLOG on Legacy Cisco switches, and it likely will do the same to Meraki switches also.  Teaching the phones the following setting stops this:  






Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.