MS125s - Constant STP changes - reason for concern?

SOLVED
DCrab
Here to help

MS125s - Constant STP changes - reason for concern?

Have a pretty simple, MX75 with two MS125 switches.. Trunks from MX to each switch. STP Root is SW1. SW2 event log shows static STP but SW1 looks like it is taking ports up and down. Am thinking of just disabling STP as can't imagine why this is happening.

 

MX Trunk to SW1 has allowed:  Native Vlan 1 and VLANs 10,20,30.  SW1 has uplink port allowing all VLANs.

MX Trunk to SW2 has allowed:  Native VLAN1 and VLANs 40, 50.   SW2 has uplink port allowing all VLANs

 

STP messages below and diagram.. I have no idea why it is changing ports 7 and 17.. They are connected to an Apple iMac and printer.. nothing weird. These changes are going on forever so thinking of just disabling STP altogether. Any thoughts?

 

 

stp.pngNetwork.png

 

1 ACCEPTED SOLUTION
rymiles
Meraki Employee

Devices turning on & off will result in events like that. Normal behavior when the ports are connected to PC's and such.

 

I would only be concerned if I saw STP flaps on ports going to other infrastructure devices like switches, firewall, routers, etc. Links that shouldn't be bouncing short of device failure or reboot.

 

Also, port 17 connected to the iMac is toggling between 100Mbps and 1Gbps. I've seen this behavior on my wired Macs and often I hard set the port to 1Gbps to stabilize it.

View solution in original post

5 REPLIES 5
rymiles
Meraki Employee

Devices turning on & off will result in events like that. Normal behavior when the ports are connected to PC's and such.

 

I would only be concerned if I saw STP flaps on ports going to other infrastructure devices like switches, firewall, routers, etc. Links that shouldn't be bouncing short of device failure or reboot.

 

Also, port 17 connected to the iMac is toggling between 100Mbps and 1Gbps. I've seen this behavior on my wired Macs and often I hard set the port to 1Gbps to stabilize it.

View solution in original post

PhilipDAth
Kind of a big deal

>Also, port 17 connected to the iMac is toggling between 100Mbps and 1Gbps. 

 

That is the "Energy Efficient Ethernet" standard at work.

https://en.wikipedia.org/wiki/Energy-Efficient_Ethernet 

Devices supporting EEE will downshift to 100Mb/s to save energy when they are idle, or you are not working hard enough.  🙂

 

I don't use Macs, but there will probably be some power saving setting that lets you disable power saving for Ethernet (and then you'll be able to leave it on auto/auto).

ah, i never bothered to look into why it does that. some articles simply say to hard set the speed on the adapter. so maybe that's the only way to "disable" eee.

Yes, with Apple devices I see the same issue, especially with Apple TV devices, also Apple TV devices are causing CRC errors on Meraki switches (but not on Cisco "classic" switches!)

DCrab
Here to help

From the replies, it seems like this is normal STP behavior. I was worried that the Spanning Tree algorithm was actually disabling and enabling ports.. but it is responding to the ports going into a power-save mode and shutting down or lowering from 1 to 0.1 gbs speed. I found that I could go into the advanced properties of the ethernet port and keep it from powering down.. but I am not concerned; since this is normal behavior. Thanks for the insights.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels