Showing results for 
Show  only  | Search instead for 
Did you mean: 

CRC Errors

Kind of a big deal

CRC Errors

We have a label printer that is plugged into the LAN in our reception which is used for printing ID tags for visitors. The port on the switch which its plugged into is reporting a high proportion of CRC errors, if repalced the patch leads at both ends, tried a different port in the switch and had the cable tested and I can't fault anything.


What should my next step be, the device doesn't used often and we have never had a problem with it not working so even if I can turn off CRC reporting on this port would be handy.


Thanks in advance. 

Meraki CMNO, Ruckus WISE, Sonicwall CSSA, Allied Telesis CASE & CAI
Head in the Cloud

Re: CRC Errors

Hi Richard,

Allow me to reiterate

1. You have changed the Port on the switch CRC remains

2. You have changed the RJ45 Jacks on both the ends of cable CRC remains (Cable remains same)


As you know most of the time CRC errors is usually the result of collisions or a station transmitting bad data.


How about trying these too.

1. Try to negotiate the Port Speed Manually if already not and check the CRC

2. Try connecting a Laptop in place of the printer and check the CRC

3. If possible bring the Label Printer closed to switch. Try connecting with a different cable ( 2/3 meter patch cord). May also repeat the step 2.


I hope you may get some answers.


Kind of a big deal

Re: CRC Errors

There might not be anything wrong.  Any chance:

* This device has a 100Mb/s port.  Perhaps something is mis-reporting on the unused pairs.

* Is a modern device that supports EEE (Energy Efficient Ethernet)?  It will probably drop its port speed when idle for a certain period of time if so.


Do you have a spare switch you could plug into that same wall jack, and the printer into that switch for a short trial?

If the CRC errors dissappear between the two switches, and move to between the temporary switch and the printer then it is something to do with the printer.


I had a customer with an embedded Ethernet port on a manufacturing machine go flakey this year after a lightening storm.  It worked but had intermittent CRC issues.  Replacing the card resolved it in that case.

Could just be a flakey Ethernet port on the printer.


Kind of a big deal

Re: CRC Errors

Yes device is fast ethernet, I have changed the device to use 100Mbps full duplex instead of auto.


I've checked for EEE settings on the device and there are none that are user configurable. 


I'll try using another switch when I get a chance. 



Thanks for the suggestions everyone. 

Meraki CMNO, Ruckus WISE, Sonicwall CSSA, Allied Telesis CASE & CAI
Kind of a big deal

Re: CRC Errors

>Yes device is fast ethernet, I have changed the device to use 100Mbps full duplex instead of auto.


Make sure you change the switch port to match as well.  🙂

Building a reputation

Re: CRC Errors

You don't mention if there is structured cabling in place so I would also say that it's often worth connecting a device directly to the switch to rule out structured cabling issues.


It's not the first time it's been an issue in the patch panel installation.

Head in the Cloud cmr
Head in the Cloud

Re: CRC Errors

I think the question poser knows the device is bad and simply wants it to stop showing errors all the time as it works, we have a number of old IoT devices with NICs that only work at odd configurations like 100Mb half duplex and produce a load of error noise.  We cannot fix them as the device hardware is 10 years old and just not very good but as they function perfectly well we'd like to turn off the error alerting for those ports.  I think this is the same issue as posed.

Comes here often

Re: CRC Errors

CRC errors in an ethernet connection are most of the times originated by a mismatch configuration Halfduplex vs Fullduplex ...
If the autonegotiation does not success, normally the devices should back to the lowest speed (10Mbps) and half duplex
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.