Adding a switch to an existing stack

cvashel2
Here to help

Adding a switch to an existing stack

I have an existing switch stack with two MS225 and need to add a third switch to the stack.  What is the procedure to add a switch to an existing stack?

 

Thanks

 

13 Replies 13
Adam
Kind of a big deal

I looked at one of our networks.  Looks like you may have to delete the stack, then create it with the 3 desired switches.  Based on my prior experience with stacking, make sure you do it during a maintenance window.  It'll likely cause some outage.  Also verify your wiring between the 3 switches so they have redundancy.  How are you wiring them?

Adam R MS | CISSP, CISM, VCP, MCITP, CCNP, ITILv3, CMNO
If this was helpful click the Kudo button below
If my reply solved your issue, please mark it as a solution.

I have the wiring part down, lots of experience with Cisco classic stacking.  I was hoping for a way to just add to the stack like you can with Cisco classic switches so i would not have to take the network down or risk it going down.

PhilipDAth
Kind of a big deal
Kind of a big deal

Plug the new switch into an existing connection, and give it a good 45 minutes to upgrade its software.  It must be running the same software as existing stack members.

 

Hopefully your existing stack has a full "ring".

 

Break the ring, and plug in your new switch, and re-form the ring.

 

Within maybe 5 to 10 minutes if you go to "Switch/Switch Stacks".  It will report there is an additional member than can be added to the stack.  Let it add it to the stack.

 

 

You are done.  Note that depending on the code version they have be a short disruption to service while you do this, so do it out of peak time.

When you say short disruption what do you mean?  Will the two existing switches stop forwarding packets?

 

thanks

 

PhilipDAth
Kind of a big deal
Kind of a big deal

I think they could stop forwarding packets for 15s.  It is a little version dependent.  This is not something I have done very often.

Adam
Kind of a big deal

My experience has been much different than @PhilipDAth.  Stacks seems to always give me trouble. 

 

@cvashel2 keep us posted on how it goes.  I'd be interested to know if Philip's more streamlined method works out so I can try using it in the future.  

Adam R MS | CISSP, CISM, VCP, MCITP, CCNP, ITILv3, CMNO
If this was helpful click the Kudo button below
If my reply solved your issue, please mark it as a solution.

so i called Meraki support and they told me to follow the procedure @PhilipDAth described and suggested that there should be no downtime.  i will report back once i have add the switch.

 

chris

 

MRCUR
Kind of a big deal

I've found that even on current 10.X firmware versions, if you break the stack ring for any reason while the stack is running, you will need to reboot the stack once the ring is fixed or you'll have issues down the road. At this point I always reboot a stack if anything happens to the stacking ring because of this. 

MRCUR | CMNO #12

so we added the third switch to the stack.  it turns out that there was only one stacking cable installed on the original 2 switches in the stack so we technically did not have to "break" the stack to add the new switch.

 

we first plugged the new switch in on an access port and allowed it to connect to the portal and any firmware needed.  once it had been green in the portal for 15 or 30 min we powered the new switch down and connected the stacking cables to form a ring and powered the new switch on.  once it came up and showed on line in the portal we added it to the stack.  after that there was about 5 minutes where the switches in the portal went yellow, warning about stacking config being out of sync.  no traffic was dropped and all switches turned green in the portal.  Meraki has also automatically scheduled a switch upgrade in a few days coincidentally so we will get a reboot for that shortly. 

 

otherwise it looks good.

HiTech
New here

We had a slightly different scenario, so I wanted to chime in as I could see it being helpful for others in the future.

 

We had two MS225 that had previously been physically stacked using a single stacking cable. We ended up with an extra stacking cable from the home office, and wanted to add that to the pair.

 

It wasn't clear to me whether we needed to power down the stack, or if it would disrupt the stack if we added the second cable while everything was up and running.

 

I waited for an early morning and tried adding the cable with everything live. It took about 3-5 minutes for the dashboard to show both stacking ports on both switches as active, but otherwise, it was super smooth and non-disruptive.

Bossnine
Building a reputation

In my experience stacking Meraki switches I've seen it go both ways.  Usually they seem to be able to stack while in use and other times I've had issues, I think it depends on the mood of the switch.  Regardless, the downtime for a Meraki switch seems to be significantly less than the Catalyst switches we replaced.

Sleiman
Here to help

I did this recently with an MS410. I had I one running as the distro and I added another one to it. It was interesting, while Meraki support said I will lose the config when I stack them that didn't exactly happen. Here's what I did and what happened: 

 

1-Bring the new switch up have it check it with dashboard 

2-Make sure both switches are on the same version 

3-Power both switches OFF and cable the stack 

4-Power the switches back on 

5-Go to switch ---- switch stacks and provision the new potential stack 

6-Dashboard will prompt you if you want to clone or ignore the configuration to the stack. Obviously you want to clone it so you don't lose it and I cloned it. 

 

The Stack came up just fine but here's the issues I ran into: 

 

1-The sapnning-tree priority went back to default so all my access layer switches had spanning-tree related issues. What I recommend is shutting down the downlinks to you access layer switches, once the stack comes back up lower the priority on it again and turn your ports back up (that's if you're stack is a distribution ofcourse) 

 

2-I lost all my aggregate ports configuration that I had on switch 1, I had to rebuild them 

 

3-And last when you stack them the L3 vlans will have a new mac-address so flush your ARP table and such. 

 

Thanks 

Hey all,

 

Here's my most recent experience with adding a new switch member to an existing stack. In my case, I added a MS210 to a switch stack in production. The switches were running the 12.x firmware and I followed these steps:

 

  • Claimed new switch in Meraki Org
  • Powered on new switch with an ethernet uplink inserted
  • Made sure it checked into the Meraki dashboard and upgraded to the same firmware version as existing switch stack
  • Powered off new switch member
  • Broke the existing stack ring and re-cabled with new switch member
  • Powered on new switch
  • Once the new switch regain cloud connectivity, I manually added the switch to the stack, and I was done

 

During my experience, I saw ~3 dropped ping packets when the new switch first powered on with the stack cables installed. I am sure everyones' experience is a little different depending on hardware models and firmware versions, but mine was very positive.

Get notified when there are additional replies to this discussion.