Windows 10 and VPN

Solved
MMoss
Building a reputation

Windows 10 and VPN

Has anyone ran into an issue with the VPN not working on Windows 10? I can get it to work on Windows 7, iOS, and Android without any issue but Windows 10 just spins on the Connecting when you try to connect. It's not hitting the Meraki and is a issue with Windows itself and not the VPN itself. We use the Windows VPN client and up until recently it's worked fine until we updated our existing equipment along with the OS. Up until three weeks ago it was working with Windows 10 and then it flatlined

1 Accepted Solution
PhilipDAth
Kind of a big deal
Kind of a big deal

It's a common issue since maybe 9 months ago when Microsoft introduced a bug into the GUI.

 

Instead run "rasphone.exe" and use that to connect.

View solution in original post

8 Replies 8
PhilipDAth
Kind of a big deal
Kind of a big deal

It's a common issue since maybe 9 months ago when Microsoft introduced a bug into the GUI.

 

Instead run "rasphone.exe" and use that to connect.

MMoss
Building a reputation

That worked, I knew Windows had broken VPN, but was under the impression it was corrected. I wish we would just spring for a client instead of relying on Windows because it never seems to work right. I'll do some more testing, but it looks good so far, thanks.

trunolimit
Building a reputation

Hey Philip,

 

I'm also having this issue where some win10 machines work and others don't. I tried to google rasphone.exe to see what is that command. could you possible explain what rasphone.exe, how to use it, and why does it fix this issue?

 

thanks a bunch.

Just go Start/Run and type in rasphone.exe.  It's that simple.

 

It is a hang over from older versions of Windows.  It uses exactly the same Windows subsystem to start the VPN.  It is just the Windows 10 GUI for starting VPNs which is broken at the moment.

Hey Philip,

 

Bingo - this always works from experience, still always good to check the VPN properties to make sure the only protocol checked is "Unencrypted password (PAP)" and then make you always connect using the rasphone client, not from the Windows Start Menu.

 

Screenshot 2019-09-25 at 13.25.44.png

 

If you don't like using the Run application everytime, you can create a shortcut on your Desktop (or push one out within GPO) to target: C:\Windows\System32\rasphone.exe

 

Screenshot 2019-09-25 at 13.29.44.png

 

Always a good reason to bring back Miles 😁

 

Kind regards,

--

Connor Loughlin
Network Support Engineer
EMEA 🇬🇧

.:|:.:|:. Cisco Meraki

I ran into this on some win10 pc's the solution was still valid, but is there anything better yet? 

Hey Matt,

 

Depending on your deployment, you may find this PowerShell script useful.

 

Note it's not an official Meraki document/solution so we cannot provide any support for it - but from personal testing, it works like a charm: https://www.reddit.com/r/meraki/comments/e97m58/3rd_party_windows_vpn_client_for_meraki/

 

See the first comment with the Pastebin link for the full code. If you don't want to go down this route, you can use a GPO to add the shortcut to rasphone.exe to users' Desktops instead. The PowerShell script works well as it removes any existing connections (that may have been changed by a Windows update) and then re-creates them. 

 

Kind regards,

 

--

Connor Loughlin
Network Support Engineer

.:|:.:|:. Cisco Meraki EMEAR 🇬🇧

For reference, many questions can be easily answered by searching our online documentation: http://documentation.meraki.com

MMoss
Building a reputation

@MattPainter701 The solution works like a charm for us. I've not tried the PS script as I just logged into the forums so I cannot comment on that solution. If you use the MDM there is an option for VPN's listed, but I've never used it before.

Get notified when there are additional replies to this discussion.