Why do my MX do VRRP when the secondary is completely offline, and has been for some time ?

Head in the Cloud

Why do my MX do VRRP when the secondary is completely offline, and has been for some time ?

We have a site that has been configured with two MX.

The secondary has only been online once, and is now offline without power and  so on.

Why do I get these VRRP transitions when the secondary is not even there ?

Its very strange.




6 Replies 6
Kind of a big deal
Kind of a big deal

Is the Primary MX trying to talk to the secondary via a keep alive and that’s what you’re seeing?


if you’ve removed and powered the device down have you removed the VRRP config.  This should clear those errors

Darren OConnor | doconnor@resalire.co.uk

I'm not an employee of Cisco/Meraki. My posts are based on Meraki best practice and what has worked for me in the field.
Kind of a big deal

If you’ve still got HA configured then the VRRP process is still running on the MX, even if the secondary is offline. A primary unit will drop its priority to 75 if it has no uplinks (WAN 1 and WAN 2) available, is this what you are seeing? Do the priority changes coincide with events on your uplinks?

I kinda gathered that the VRRP process would still be running, because the secondary is still in the configuration.


There does not seem to be a uplink down, BUT, when you look at the eventlog, you can see that it drops all its VPN connections, and then the DREADED : Events where not logged.

This indicate that something definitely has happened.

But I cant see what, this is of course very frustrating for both me and the customer.


Could I get these "dropped" events by setting ip a syslog server ?


The last time I tried that, nothing was registered on the syslog server. 😕

When we look at the connection graph for the same period there is nothing to see.



Hmmmm could this be the DHCP lease time on the WAN thats kicking in ?

It pretty much every 6 hours.

I was not aware that this customer used DHCP on the WAN.


This, of course, brings the next question, is there a way to see the lease time of the WAN on a MX ? 🙂

(Im guessing no).



Kind of a big deal

Are they consistently occurring every six hours? Maybe it’s a VRRP timer of some sort kicking in, but you’re correct, there doesn’t seem to be any uplink state changes. The easiest was to solve it is like has been said, remove the HA configuration if you’re not using it. Otherwise you could log a support case and see if they come up with anything.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.