VMX100 support for Azure CSP Subscriptions?

Here to help

VMX100 support for Azure CSP Subscriptions?

Hi All,


We have an existing client that would like to deploy a VMX100 in Azure. They currently have an existing CSP subscription they would like to continue using.


I have seen an old thread from 2017 stating it is not possible to deploy a VMX100 in Azure on a CSP Subscription.


Can anyone confirm if this is now supported or if we need to recommend an alternative NVA to the client to meet their needs?

Kind of a big deal

You can now use the VMX with CSP.

That's great news thank you. I don't suppose there is an announcement or blog post I can refer to when talking about this internally at all is there?


In my recent investigations I did sneak about a potential work around a few years back. I'm assuming no workarounds are required anymore?

I can't find any documentation saying it is now possible.


I think I have done three VMXs into CSP Azure tennants now without any special tricks.



Even when it wasn't natively support you could still do it using this workaround:


That's fine. Thanks for the responses. Much appreciated. 👌

Just to give everyone an update. I did just hear back from Meraki Support stating it's still not possible without the workaround. They provided the same link and workaround as posted in the thread from 2018.


So while I appreciate your experience and saying it can be done, if in writing Meraki are saying it's still not possible without the workaround then I'll have to defer to that unfortunately when discussing back internally. 

Give it a try your own tennancy... About a 10 minute test to see if it will work. 



Do you have a working link? This looks like it's a Cisco Employee link.

@CameronMoody  is the below still a valid link (and had public access removed) or has the document been removed?


Thank you. It would be good to get this clarified. I had saved the article from before however the link in it to download the template no longer works and when I tried to access the article again to check that was when I realised it looked like it may have changed \ been removed.

That is a good refresh of that info.  The whole CSP bit is gone now.  I guess it shouldn't be needed anymore.

I raised a ticket with support earlier and they responded with the following:


"As discussed on the phone. The vMX100 deployment with Azure CSP is DEPRECATED and no longer available."


Frustratingly I'm back at square one and don't know what to believe. Sorry to drag you into this as you've been really helpful but issue is I need written confirmation from Cisco that it is a supported configuration and have been unable to find it.


The problem I have now is do I take the risk and purchase a license I've been told by support is no longer going to fit our requirements or look for an alternative solution for our client. 

To be clear there is no longer a special csp deployment because you can just install directly from the marketplace.


Im a csp partner and have deployed multiple vmxs for multiple customers.

Thank you. I appreciate you're response and believe what you say but I'd like to get it in writing from Meraki. The fact I'm erring to think you are right just frustrates me even more because the official line I got was it's now deprecated.


When was the last time you deployed a Meraki appliance on a CSP Azure Subscription?

I'd talk to your rep, but you need to realize, the special CSP thing existed b/c it was the exception to the rule.


You are asking for something in writing to confirm that a special setup method that is not normal no longer exists.


It's deprecated b/c it's no longer necessary to follow one setup method if you are CSP and a different way if direct, not because it no longer works.


The worst thing that happens is you RMA the license with disti.


I literally deployed this in the past month.

I am waiting back on a call from our sales rep. There is a world of difference between not stating a particular use case is supported and support explicitly telling me that support for that use case has been deprecated. It may be support have given me the wrong info however I have had two different people on the ticket so that would mean they were both wrong.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.