cancel
Showing results for 
Search instead for 
Did you mean: 

No connection to WLC

SOLVED
Conversationalist

No connection to WLC

Hi,

 

I am using a MX65 in a location and got Cisco AccessPoints (AIR-CAP1602I-E-K9) in use.

 

When I sent an AP (factory defaults) into this location it is getting an IP but not connecting to my WLC here in the headquater. Before using Meraki, we used Cisco Router, where I needed to configure 2 udp forwardings and one helper-address.

If I´m doing the setup before I sent the AP into the location everything works, when it´s connected on-site.

 

As far as I see, udp forwarding is not the solution at Meraki, but I don´t find an solution and the support says I have to get in contact with Cisco, but don´t have a responsible person and also don´t understand what he wants me to do.

Tried it with dhcp option 43 as well, without succes.

 

Has had anyone this problem and solved it? Would be grateful for any kind of help.

 

Thanks,

Marc

1 ACCEPTED SOLUTION

Accepted Solutions
A model citizen

Re: No connection to WLC

https://shimi.net/services/opt43/

 

You have your information criss-crossed

 

10.0.1.199 = 0a.00.01.c7 which means option 43 = f1040a0001c7

 

10.0.1.201 = 0a.00.01.c9 which means option 43 = f1040a0001c9

 

So in your case the DHCP option 43 will need to be set to "f1040a0001c9" and hopefully it will start working =)

Nolan Herring | nolanwifi.com
TwitterLinkedIn
12 REPLIES
ww
Head in the Cloud

Re: No connection to WLC

did you  make packet captures on the mx lan and wan and maybe looked what is blocked or not responded to. 

A model citizen

Re: No connection to WLC

Can you provide a screenshot of how you have Option 43 configured?

Also are you able to provide the console output from the AP after you turn it on.

Might be worth trying to set up the port forwarding via the following guide using these ports. Not sure if this will work though.

https://documentation.meraki.com/MX/NAT_and_Port_Forwarding/Port_Forwarding_and_NAT_Rules_on_the_MX

ip forward-protocol udp 12222
ip forward-protocol udp 12223
ip forward-protocol udp 5246
ip forward-protocol udp 5247
Nolan Herring | nolanwifi.com
TwitterLinkedIn
Conversationalist

Re: No connection to WLC

@ww:No, to be honest didn´t do that so far, but will do that today... But I´ll set up an Test location and do it there...

 

@NolanHerring

 

2018-11-23 08_52_15-DHCP Configuration - Meraki Dashboard.png

Getting noticed

Re: No connection to WLC

Try setting the hex value without colons. I.e. f1040a0001c9
Conversationalist

Re: No connection to WLC

Don´t know why, but in my test location it is working... using my default settings.

 

Does anyone know what the Value stands for? I can´t confirm it is the MAC address of the WLC...

Getting noticed

Re: No connection to WLC

Option 43 is not the mac address of the WLC.

It is the IP address of the WLC in Hex format.

 

See Cisco's document on option 43 

https://www.cisco.com/c/en/us/support/docs/wireless-mobility/wireless-lan-wlan/97066-dhcp-option-43-...

 

A model citizen

Re: No connection to WLC

Give me the IP of your WLC and I can convert it to the correct hex format
Nolan Herring | nolanwifi.com
TwitterLinkedIn
Conversationalist

Re: No connection to WLC

Old is 10.0.1.199 --> f1:04:0a:00:01:c9

New is 10.0.1.201 --> ?? can´t convert it to the correct format, always getting: "0a0001c7"

 

Can you provide an webpage?

Getting noticed

Re: No connection to WLC

TLV values for the Option 43 suboption: Type + Length + Value. Type is always the suboption code 0xf1. Length is the number of controller management IP addresses times 4 in hex. Value is the IP address of the controller listed sequentially in hex. For example, suppose there are two controllers with management interface IP addresses, 192.168.10.5 and 192.168.10.20. The type is 0xf1. The length is 2 * 4 = 8 = 0x08. The IP addresses translates to c0a80a05 (192.168.10.5) and c0a80a14 (192.168.10.20). When the string is assembled, it yields f108c0a80a05c0a80a14. The Cisco IOS command that is added to the DHCP scope is option 43 hex f108c0a80a05c0a80a14.

 [link]

 

In your case;

Type: 0xf1

Length: 0x04

Value: 0x0a.0x00.0x01.0xc9

 

Therefore; f1040a0001c9

A model citizen

Re: No connection to WLC

https://shimi.net/services/opt43/

 

You have your information criss-crossed

 

10.0.1.199 = 0a.00.01.c7 which means option 43 = f1040a0001c7

 

10.0.1.201 = 0a.00.01.c9 which means option 43 = f1040a0001c9

 

So in your case the DHCP option 43 will need to be set to "f1040a0001c9" and hopefully it will start working =)

Nolan Herring | nolanwifi.com
TwitterLinkedIn
Getting noticed

Re: No connection to WLC

 


@NolanHerring wrote:

https://shimi.net/services/opt43/

 

 


Awesome link; hereby bookmarked. Smiley Happy

Conversationalist

Re: No connection to WLC

Thanks all for your help, its works now Smiley Happy