MX67C-NA Internal SIM Issues

dubbs
Here to help

MX67C-NA Internal SIM Issues

I am having a hard time getting any type of answer for the issues I am having with the internal SIM working on the MX67C-NA device. 

 

I am using a SIM card from Verizon in the device. I have been told by Verizon and Meraki that Verizon has been certified to work with the MX67C-NA, but I am unable to get the sim to work in the device. 

 

Actions taken:

 

Activated the SIM card with Verizon using the IEMI of the device ( with and without a static IP )

Update the APN in the Meraki portal (security & SD-Wan->Appliance status->Uplink->Cellular->APN)

Contacted Meraki TAC to upload the APN on the back end - hard code

Update the firmware to the 14.53 as suggested by TAC

Removed the SIM put in phone and ensured it is getting a connection to the network - in a good service area - put back in the MX67C-NA - as suggested by Verizon

 

I have not had any luck with a connection, it will appear in the portal as connecting, enabled for a second or 2 then revert back to the Enabled state. I seem to be getting no where with any support on the Verizon side or the Meraki Side. We are in the US, if that makes a difference. Not sure what else to do.

 

We do have an external Cradle Point device connected to Port 2 as our failover, but we specifically got the MX67C-NA for the ability to use the internal cell connection, to not spend more on the external solution. We are not having any issue with the Cradle Point solution.

 

Any help or suggestions would be Awesome!!!

 

Thank you

 

14 REPLIES 14
UCcert
Kind of a big deal

Re: MX67C-NA Internal SIM Issues

Found this post:

 

https://community.meraki.com/t5/Security-SD-WAN/MX68CW-and-Verizon-SIM-Card-Issue/m-p/87535#M22112

Darren O'Connor | uccert.co.uk
https://www.linkedin.com/in/darrenoconnor/

I'm not an employee of Cisco/Meraki. My posts are based on Meraki best practice and what has worked for me in the field.
dubbs
Here to help

Re: MX67C-NA Internal SIM Issues

Thank you for the quick reply, I should have mentioned the APNs i have tried. 
 

vzwinternet

vzwapp

so01.vzwstatic - for the SIMs with a static IP and the Area codes they are activated in - according to Verizon

 

 

Aaron_Wilson
A model citizen

Re: MX67C-NA Internal SIM Issues

vzwinternet is the correct apn. It's what I have on my mx67c.

 

Have you connected it via hard wire first? After that, remove the hardwire and give it a solid 5 minutes.....just don't touch it. Sometimes mine acts goofy on initial load.

 

Otherwise, it's been working great on Verizon.

PhilipDAth
Kind of a big deal

Re: MX67C-NA Internal SIM Issues

Dumb question.  I see you are using the US version of the MX67C.  Are you located in the US?

dubbs
Here to help

Re: MX67C-NA Internal SIM Issues

The APN to use with a SIM that has a static associated with it in the south area, is the so01.vzwstatic - that did not work with a static. 

 

The APN to use with a SIM that does not have a static is the vzwinternet - that is not working either

 

Which is the main issue, I have tried all the ways i can think of to no avail.

 

The ISP main connection is constantly connected via port1 and the internal cell will show no signal 

dubbs
Here to help

Re: MX67C-NA Internal SIM Issues

yes in the US

 

cmr
Kind of a big deal
Kind of a big deal

Re: MX67C-NA Internal SIM Issues

Have you tried the MX15 firmware, it is updated far more often and may work differently, if it doesn't work you can always roll back to MX14.

dubbs
Here to help

Re: MX67C-NA Internal SIM Issues

If I am not mistaken the 15.x firmware is beta. That is something my company does not want on our prod equipment. We are only to use the SRC and RC at this time.

 

Thank you

cmr
Kind of a big deal
Kind of a big deal

Re: MX67C-NA Internal SIM Issues

That is why I said try, if it is also broken then that is good info for the Meraki techs, if it is not then you have a choice.

ZeeBoussaid
Getting noticed

Re: MX67C-NA Internal SIM Issues

hello, have you ever got this issue fixed? im having the same issue and i just updated one of my MXs to 15 for testing and the LTE is showing no signal, Meraki keep saying the APN vzwinternet is correctly applied to all my MXs but keep suspecting the SIM card tray, they requested a hard reboot which i did, nothing seems to get the signal back. keep in mind the MX in question was initially installed with Sim card at the beginning, and it had a poor signal until couple months ago where the LTE uplink keeps showing no signal at all. 

dubbs
Here to help

Re: MX67C-NA Internal SIM Issues

After many discussions with Meraki and their engineers, the resolve to this issue was to activate the internal SIM card, after confirmation of the SIM being active set the internal modem to "enabled" - for some reason it setting to "enable" before the SIM is active, the MX doesn't like it, I have seen this on many many of our MXs. While the MX is plugged into power, remove the SIM tray, unplug the MX, re-install the SIM card while the MX is unplugged, Plug the MX back in.

 

That has solved most of the issues I have seen, and to be honest I completely forgot about this thread, and I never let yall know of the fix. 

 

Few of the MX devices we had to replace the internal SIM cards with new ones as the MX would just not recognize there was an SIM installed.

After preforming the above, we didn't need to add the APN, it finally pulled that info from the carrier, in this case it was Verizon.

ZeeBoussaid
Getting noticed

Re: MX67C-NA Internal SIM Issues

thank you for the update, i contacted Meraki and opened a case, they keep insisting the APN is applied correctly to all our MX, i tried to hard reboot and the steps you mentioned and the MX sim modem will not pick up a signal. Meraki most likely will advice to RMA these MXs and we are talking around 100 of them! that's something im not looking forward to.

dubbs
Here to help

Re: MX67C-NA Internal SIM Issues

When i was going through this, i requested that they hard code the APN on the back end, which never really worked. Try requesting the hard coded APN be removed from their side. I had to do this as well. Then try the rebooting process over again. So far this has worked with over 500 MX67Cs at the company i work for. This worked for internal SIMs that had static IPs assigned and SIM that had no static IP assigned.

 

Thank you

ZeeBoussaid
Getting noticed

Re: MX67C-NA Internal SIM Issues

thank you, i just requested the hard coded APN to be removed from my MX, ill update once that is done in the backend.

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.