MX 18.107.2 firmware killing or disabling USB port on MX65's

Comes here often

MX 18.107.2 firmware killing or disabling USB port on MX65's

We've recently had 117 Meraki MX65's receive MX 18.107.2  (upgrading from MX 16.16.9), and now the USB LTE dongles plugged into their USB ports for a failover link no longer show in the dashboard on the networks. The cellular line in the network connectivity graph ends on the date these upgraded.


We've tried rebooting devices, no change.

We've tried failing over to the cellular to see if it kicked in, nothing.

I've tried 3 separate LTE dongles (several generations of the same "supported" device), all act as though they are dead.


The LED's on the dongles that show power and connectivity no longer light up either (but do if plugged into a computer). It's as thought MX 18.107.2 either turned off or killed the USB port.



Has anyone else seen or experienced this? 

And reading other comments, it sounds like we should step right back to MX 16.16.9 for complete reliability, especially as there is RADIUS involved... Is this a fair comment?


(Yes, I have logged a case with Meraki Support. I'm curious to see if anyone else has experienced this - as MX 18.107.2 has been out for at least 6 weeks.




Getting noticed



"USB modems with MX/Z series devices running firmware MX 18 or newer will be limited to best effort support and will not be receiving any future firmware fixes or improvements."

Guess USB Dongles will never work again to sell more C-devices.

Kind of a big deal
Kind of a big deal

I don't think that best effort support should equate to disabling the devices.  I'm thinking there is a bug here...


Just noticing this with my MX65's after upgrading late last month.  I've got two MX65's with the exact same issue that were working fine before 18.107.2.  Tried upgrading to 18.107.4 and still see the problem.  I have an alternate MX67 at another site where it's working fine.


Were you able to find a resolution to the issue?  I just opened a support case to see what they say.  And I understand they are pushing us off of USB modems, but the modem is on the supported list and works fine on alternate hardware.


In case anyone else runs into this, 18.107.5 released a couple of days ago fixes the USB Modem issue on MX65's.


  • Resolved an MX 18.1XX regression that resulted in peripheral devices, such as the USB port, not receiving the correct amount of power on MX65(W) appliances.

Two sites with MX65's work fine again after upgrading.

Comes here often

A quick update here - so the root issue for the USB dropping from the MX65's under MX 18.x firmware was that some bad coding meant that the MX65's were not providing enough power over the USB for device to run - such as USB LTE dongles. So this has been resolved in firmware version MX 18.107.5 .  This might be the only version it is resolved for, we wait to see.

I've done a huge amount of testing upgrading the firmware to MX 18.107.5 under various scenarios and I can confirm that this firmware version does 100% fix the issue. 

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.