cancel
Showing results for 
Search instead for 
Did you mean: 

Group policy Youtube Filtering Not Working

Here to help

Group policy Youtube Filtering Not Working

Morning all,

 

I have an MX65 with content filtering, youtube filtering etc. One of the teachers in school needs to have unfiltered access to youtube. I created a new group policy and applied that to my machine and the teachers one, both however don't work with the group policy assigned. I've tried clearing cache etc but has anyone else got any other ideas?

 

Internet - Modem (Bridged) - MX65 - Server - Clients

 

DG is set to the MX65, DNS settings and everything else pushed from the local server.

 

Thanks,

Stu

7 REPLIES 7
Kind of a big deal

Re: Group policy Youtube Filtering Not Working

So I assume you blocked youtube with the L7 firewall rule in the MX firewall? Something like this:L7_firewall_block_youtube.PNGL7 Firewall Block

 

And then in the new group policy you created you selected custom firewall rules: 

allow_youtube_group_policy.pngAllow Youtube Group Policy

 

And then you applied the policy to the clients like this:

 

group_policy_applied_on_client.PNGApply group policy to client

Correct?

 

I tested it and it works for me. It only blocks the actual video stream though, the website itself loads fine. During testing I gave it some time to sync the MX configuration and restarted my browser. Sometimes it took a little while to actually start doing what I configured it to do.

Kind of a big deal

Re: Group policy Youtube Filtering Not Working

What version are you running? We had problem with YouTube for schools in versions prior to 14. If you're not on a 14 version I would suggest upgrading. 

Kind of a big deal

Re: Group policy Youtube Filtering Not Working

Also note if the client has accessed something recently and then you apply the group policy the client can continue to access it for a while until the MX expires the flow out of its cache.

 

Usually waiting 10 minutes (or rebooting the MX) is sufficient.

Here to help

Re: Group policy Youtube Filtering Not Working

Morning all,

 

Thank you all for your help, basically I have just changed the Youtube settings under Content Filtering, so we have the following:

 

Screenshot 2019-01-10 at 15.14.30.png

 

We have no firewall settings for youtube so surely it should be relatively simple if the group policy is applied?

When on site yesterday I tried rebooting the MX65 but no luck.

 

Screenshot 2019-01-11 at 08.51.52.png

Here to help

Re: Group policy Youtube Filtering Not Working

It's on 13.36, how would I go about upgrading to 14??

A model citizen

Re: Group policy Youtube Filtering Not Working

Hi Stu,

To upgrade the Firmware one should have "Organization Wide" admin Rights.

 

You will see "Firmware Upgrades" option under "Organization".

 

Screenshot attached for reference.

 

Firmware Update.PNG

 

Cheers
Ajit
ajitsnw@gmail.com
Highlighted
Here to help

Re: Group policy Youtube Filtering Not Working

Just a quick update as I'm only on site once a week, I tried changing the DNS server address to Google's and OpenDNS, once I closed and reopened the browser the group policy setup on the MX65 worked as it should do Smiley Happy.

 

Is there any reason why my ISP DNS would be causing the issue? I'm going to contact them but was wondering if anyone had any thoughts on why changing the DNS address to OpenDNS would be a bad move?

 

Thanks,

Stu

 

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.