Failover to Secondary Hub Not Working

SOLVED
JamesMutie
Conversationalist

Failover to Secondary Hub Not Working

I have configured primary and Secondary Hub  with priorities set for all the spokes and advertising a static route into auto VPN to be received by the spokes. When the primary hub goes down the static route does automatically failover to secondary hub unless we stop advertising into autovpn from the primary hub. I wonder why the static routing is not failover automatically despite  seeing the two routes in the route table

1 ACCEPTED SOLUTION

Accepted Solutions
ww
Kind of a big deal
Kind of a big deal

Re: Failover to Secondary Hub Not Working

I cant tell why this dont work either but if remember correctly  its known behaviour of static routes in vpn. 

 

If you want redundancy you could use warm spare setup combined with static route. Or use one-armed hub setup with dynamic  routing/bgp

View solution in original post

3 REPLIES 3
ww
Kind of a big deal
Kind of a big deal

Re: Failover to Secondary Hub Not Working

I cant tell why this dont work either but if remember correctly  its known behaviour of static routes in vpn. 

 

If you want redundancy you could use warm spare setup combined with static route. Or use one-armed hub setup with dynamic  routing/bgp

View solution in original post

JamesMutie
Conversationalist

Re: Failover to Secondary Hub Not Working

@ww The setup for hub to spoke is via autovpn over internet so I only remain with one option of advertising the static routes into autovpn.

JamesMutie
Conversationalist

Re: Failover to Secondary Hub Not Working

We managed to achieve a seamless failover of the implemented solution after Cisco Meraki TAC Engineer disabled auto summary a backend feature not available on dashboard which was causing the havoc.  What the engineer said is that the two hubs perform auto summary ,  and the summary starts being preferred over the static route which is  a bit weird and we could not get answer why the summary route has a better AD.

 

If you facing the same problem ,I recommend  you open a TAC case and let them disable auto summary feature if you do not use it in your network.

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.