cancel
Showing results for 
Search instead for 
Did you mean: 

Device on Network Has no IPv4 address

SOLVED
Just browsing

Device on Network Has no IPv4 address

I have an Ubuntu VMWare instance on my network that I want to set to a fixed IPv4 address but in the dashboard it only shows an iPv6 address even though I know the IP it is currently running on.  It also shows as not connected but it is because it is hosting active VPN connections.  Does anybody know why it's not showing the IPv4 address and how I can get it to do so in order to set it to fixed so the IP doesn't ever change?  Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Kind of a big deal

Re: Device on Network Has no IPv4 address

Lets try doing it manually.

 

Go "Security & SD-WAN/DHCP".  Then add a manual DHCP assignment like this:

dhcp.PNG

 

7 REPLIES 7
A model citizen

Re: Device on Network Has no IPv4 address

So in the Network Wide > Clients you only see an IPv6? When you click on the client it doesn't show you an IPv4

 

Kind of a big deal

Re: Device on Network Has no IPv4 address

@VI-AHart  how is the network interface on the VM setup i.e. it is bridging or using another method?  Is your network actually using IPV6?

Meraki CMNO, Ruckus WISE, Sonicwall CSSA, Allied Telesis CASE & CAI
Kind of a big deal

Re: Device on Network Has no IPv4 address

Typically when it doesn't show this information it is because the device isn't generating IPv4 traffic.

 

But if you can see the device, even though it currently only shows an IPv6 address, you should still be able to fix the IP address from the clients page using the drop down box.

 

client.PNG

Just browsing

Re: Device on Network Has no IPv4 address

IPv4 in the client says null. I know how to lock it down to fixed it just isn’t showing one for me to modify. 

Just browsing

Re: Device on Network Has no IPv4 address

Not sure about the VM instance because I didn’t set it up. Network is using ipV4 and this is the only device with this issue. I’m not familiar with Ubuntu only windows VM’s so I assume that’s the difference just don’t know how to fix it.

Highlighted
Kind of a big deal

Re: Device on Network Has no IPv4 address

Lets try doing it manually.

 

Go "Security & SD-WAN/DHCP".  Then add a manual DHCP assignment like this:

dhcp.PNG

 

Just browsing

Re: Device on Network Has no IPv4 address

Setting it manually by MAC address worked - thank you so much!

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.