Meraki Go Subscription no place to add and security screen is blank

Just browsing

Meraki Go Subscription no place to add and security screen is blank

Purchased umbrella security.

Received code via email and clicked on "claim subscription".

Opens app on PC, enter password, goes to my network.


Then nothing.   No security link is available off main settings page.  


Security page on GX50 does not load and crashes the app.


What is going on?

7 Replies 7
Just browsing

Found this:  



Add in my number and it just spins and then does nothing.

A model citizen

I had this problem a few weeks ago…exactly


you have to do this on the website…can’t add a license from the phone app.



i waited to off hours …after mid nite…loaded the code it accepted it…silently…


apparently either the license server is bogged down or the firewall in front of the server is bogged down.




checked for security features…no obvious change



sumbitted a tictet


had to go to the org, and find a ribbon, click on it…so that the subscription can be applied.








New here

Once you applied the subscription it worked?  I had no problem applying the subscription but when I go to the security section the page just never loads.




hello @mplewis299 


did you sign off from the app and sign back on?


I can't say it will solve the issue, but sometimes the app needs a reset to work properly.



A model citizen

So applying the license is different than loading it.

first step is to load the license key…and this can only be done on the website…not the phone app.  There is definitely a sluggishness going on.  It will spin for quite a while.


then after it’s loaded…or when you see a ribbon at the top of the org and company…you have to select the ribbon and pick apply.  This is a new step…wasn’t like that before.

 Also…fyi…I had to submitt a ticket and after doing so…things worked…maybe they restarted the service or something.



Completed all these steps already.  They finally responded to my ticket - unexpected behavior - with development - no ETA.

Related—-just found out that the gx-50 does not block url or block content for ip6 devices….which almost all human use devices are.

submitted a ticket and support said that the gx-50 is not an ip6 gateway.  Even though it uses ip6 ip’s.

trying to find a way to force ip4, maybe add a dedicated ip4 dhcp server, etc



i tried to reserve ip4 addresses by mac but the gx-50 issues both ip4 and ip6




Get notified when there are additional replies to this discussion.