Issue with iPhone clients

Getting noticed

Issue with iPhone clients

Hi all,


Yes again, different customer, different Meraki Go network - inconsistent connectivity with iPhone! Sometimes iPhone will work fine, other times iPhone displays "No Internet Connection" and checking there is no IP address which is the reason for lack of connectivity. 

BUT ... this is as simple network one router and one GR10 - no wireless configured upon the router. Router has a 900Mbps connection which is not experiencing any issues and very reliable. 


Windows laptops work fine, iPhone anything could happen.


Have tried adjusting Apple "private addressing" options, no difference. Configured band steering, no difference.


Any other suggestions?



19 Replies 19
A model citizen

Just a couple of questions for you if you don't mind.


1. Is this install a single AP or multiple?

1.a If multiple can you verify if each AP does not have channel overlap.
2. Does this issue happen on multiple iPhones?

3. Did you turn band steering off or on?

4. What version of iOS are you on?

5. What channel widths do you have configured?


Things to try

1. Turn wifi off and back on.

2. Renew IP address on test iPhone.

3. Forget the network and reconnect. 

Hi and thanks for your email


In answer to your questions.


1. In this instance its a single AP - other installations have multiple APs

1a. In this instance its a single channel, typically set to 6 in 2.4GHz. Other installation I generally avoid channel 1 - so either 6 or 11 

2, Yes and inconsistently - often seeing RADIUS or DHCP issues but nothing more in depth.

3. Band steering on, Bridge mode on.

4. Latest iOS - 15.6.1 

5. Channel widths not changed from default



1,2 and 3 - no difference

Even tried Full Reset of network settings


A model citizen

Can you try the following settings one by one then test?

1. Navigate to Networks / SSID / Settings / Advance Settings / Radio Settings / Dual Band (Not with Band Steering)

Allow time to settle and verify if the dropping continues

2. Navigate to Hardware / Select the AP / Radio Settings / 5 GHz band / Channel width / Select 40 MHz / Then click Apply.

3. Verify the channels are manually set and not on auto.



well some success in making the changes with regard to iPhone but laptops reverted to 2.4Ghz 


So removed changes. iPhones stabilised then after a couple of hours, lost connectivity, and then reverted to original issues. Laptops were fine and back on 5Ghz


making no sense.


had a spare Netgear Orbis - it worked for all clients! 




 since you mentioned 2.5ghz vs 5ghz can try "dual band operaton with band steering" instead of selecting 2.5ghz or 5ghz.


to do that


select the wireless network

select settings

select advnaced settings

select radio settings

select  "dual band operaton with band steering" instead of selecting 2.5ghz or 5ghz.

Thanks - take a look at the previous thread items - the band steering is a default for my installs - the issue being iphone stability, which they aren't

Did you make all the changes at once?

No - the changes were made over the space of a couple of hours

Meraki Alumni (Retired)
Meraki Alumni (Retired)

EDIT: I re-read the description of the issue and see that there is intermittent islands of stability. Take the following post as just some insight from someone hearing your plight, I'm not sure if I'm hitting the mark or not.


I noticed a shift a few years back (a decade now maybe?) where wifi connections were demarcated as failed to connect or no internet connection on the mere premise that DNS is failing. In testament to this, if I block DNS on my home network that my Meraki Go wifi clients use - they start to complain that the wifi is not working. The reality is, this health check on the mobile is entirely based on "is DNS working?". My android devices will connect in these circumstances, but say "Connected, no internet".


I bring all of this up @IanTerry because this shift in the industry has made it harder for us, remotely, to tell if you are having wifi issues (like interference) or an issue on the wire upstream of the access point. Both of these can cause DNS to fail, and have the wifi marked as no good.


If the changes recommended thus far haven't given much insight - it might be time to check the local status page of the GR10 and get more information. Ideally, we'd want to know:


- Which band you are on during the slowness

- What is channel utilization during the slowness

- What are your speeds directly to the access point

- What are your speeds to the internet


The local status page offers info on your connection, like which band, channel utilization, and also provides a speed test to let you see what your local speeds are. We'd want to pair that with the internet speed test taken immediately after the local status page speed test, as well as identify if there is a channel utilization problem or interfering access points in the area.


Also shout out to @speakerfritz and @TyShawn for jumping in. It takes a village!

thanks for the comments - I have been attempting a few things. 


Router is a constant, ultimately LAN is connected to it. Summarised results with Meraki Go, iPhone performance is inconsistent. Netgear and Aruba, no issues. 


Replicated baseline configuration across all platforms - for example, changing channel width, same physical location. 


All APs use DHCP client, ensuring routers is rebooted when changing vendor AP. 


Same issues with iPhones!


The only consistent failure that i found, was Test to an Internet site from the AP, it failed. Test to meraki go passes!! Clients connected to the AP work fine apart from iPhone consistency!


So from what I can see there is a DNS issue but its isolated to the Test Connection on the Meraki AP 

Just for giggles can you set your DNS to and on your iPhone IF your router is set as DNS. If the DNS server is something external can your set DNS to your router? Lastly it may be time to break out wireshark when the issue is taking place and poke around with the findings. One last question and I just skimmed the post what firmware are you on with your APs?

Manually changing the DNS IP address was something that I tried early on. Made no difference. 

there is something odd with GO aps and DNS - using test connection, test to Meraki Go is fine, test to fails. 

not convinced the central management platform is particularly stable either. Had issues indicating no hardware then two minutes later hardware appears.


think it’s time to reevaluate Meraki Go as a solution - the reliance of network is something I can’t give to the end user. Don’t like Netgear, but that has worked every time !

I understand but before you go that route it is worth pulling a packet capture to see what you may be seeing.

Not sure what you'd expect to see but used wireshark and DHCP from router is ending all the correct information that you'd expect. I actually changed the DHCP configuration so that DNS would be Google and 4Nines - made no difference. 


Ultimately configured static IP address and DNS - and that works. Raise a technical support case with Cisco but nothing coming back that I have tried. I would say that static configuration will work but obviously not ideal in the world where this solution is deployed.


Thanks anyway, 

Meraki Alumni (Retired)
Meraki Alumni (Retired)

99 times out of 100 the pcap holds the truth. If you have a capture from when the issue was occurring, we could probably get to the bottom of the problem. I think support was the right way to go.


There have been some reports that cases weren't opening properly today - did you happen to get a case properly generated when you contacted support? I'm just curious, making sure there isn't an issue out there. We definitely want to be sure support is getting back to you.

A model citizen

What are the network ip’s on the two routers that work ok vs the Meraki go router?


any chance of a double nat ?





what is ip’s of the first good router

what is the ips of the second good router


what is the ips of the Meraki go dhcp?


what is the carrier ip address of the iPhone service provider


is the carrier up address network the same ip of the Meraki go dhcp.



2nd router?? No, this is a single router site.


Don't worry - have a static configuration workaround

No chance of double NAT. 

Get notified when there are additional replies to this discussion.