iMessage issue

SSDD
Comes here often

iMessage issue

Hi, I have enrolled a few iPhone 11s through Meraki and I have disabled Apple ID in all devices but enabled iMessages. Our staff is not receiving texts from external people who are using iMessage. Can anyone help me or anyone else facing these issues?

 

Thanks

SD

8 REPLIES 8
PhilipDAth
Kind of a big deal
Kind of a big deal

I don't know the answer, but wouldn't Apple ID be required for iMessage to work?  Doesn't iMessage work by sending messages to the Apple ID associate with the number?

BlakeRichardson
Kind of a big deal
Kind of a big deal

Apple Messages require an Apple ID to work otherise how does Apple know where to send messages to?

SSDD
Comes here often

Hi All, 

 

Thanks for your reply.

We have enabled iMessage in Merki, but disabled Apple ID. We can not register the mobile number as send and receive address. Please see the screenshot below. Technically this should work, like someone using an iMessage with Apple ID and sending a text to an Android user.  

 

The issue we are facing is staff does not receive a text from the device signed with Apple ID and using iMessage. 

 

SSDD_0-1627526122323.png

 

@SSDD  You have not read my previous reply.  Apple iMessage requires a Apple ID to work. 

HI @BlakeRichardson I did read your message.

 

What if someone sends a text from an Andriod mobile to an Apple? we would receive it right? Without using an apple ID the normal text messaging service should work in the Apple phone, and the phone should pick up the mobile number as send and receive address. In our case, this is not happening. and that is my question. I have this issue only after we restrict our staff from adding Apple ID to their work phone.

 

I hope this is clear.

 

Thanks,

 

Bruce
Kind of a big deal

@SSDD I don't know if this is the answer - or if the MDM will let you do this - but have you tried disabling iMessage entirely? As has been said, iMessage is Apple's own solution that builds on the basic SMS functionality. I'd disable iMessage entirely and see if you then get standard SMS capability. I wonder if having iMessage enabled with no associated number or Apple ID is causing iOS to dummy spit.

SSDD
Comes here often

Hi, @Bruce Thanks for your reply.

 

Yes, I did disable iMessage and tried, but no luck. I could only fix this by creating two profiles, one with Apple ID and the other without Apple ID. First I add the device to the Apple ID profile, add the send and receive the number and then move the device to profile with no apple ID. 

 

The only issue is if the device did any iOS update and restarts, this will lose the send and receive address. 

 

Wondering if there is anything that needs to be changed from the initial enrollment settings when we sync devices from DEP. 

 

I will give it a try and update it in the next few days.

 

Many thanks to @All

@SSDD  iMessage and the Messages app are two different things. Yes you send iMessages using the message app just like SMS as you mentioned but your original post said you had enabled iMessage hence my comment. 

 

Yes the messages App can be used without an Apple ID however if you want to send iMessages using the Messages app you need an Apple ID. 

 

 

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels